classification
Title: Python doesn't compile on Microsoft Visual Studio 2008 "Orcas" Beta 2
Type: enhancement Stage:
Components: Build Versions: Python 2.6
process
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: Nosy List: loewis, swaroopch
Priority: normal Keywords:

Created on 2007-09-13 14:35 by swaroopch, last changed 2007-09-14 06:53 by georg.brandl. This issue is now closed.

Messages (4)
msg55891 - (view) Author: Swaroop (swaroopch) Date: 2007-09-13 14:35
I followed the README build instructions for VS2005. I opened
pcbuild.sln in PCbuild8 directory and tried building, and I get the
following errors:

<start of errors>


Warning	1	Command line warning D9035 : option 'Wp64' has been deprecated
and will be removed in a future release	cl	make_buildinfo
Warning	2	Command line warning D9035 : option 'Wp64' has been deprecated
and will be removed in a future release	cl	make_versioninfo
Warning	3	warning C4005: 'WRITE_RESTRICTED' : macro redefinition
c:\program files\microsoft sdks\windows\v6.0a\include\winnt.h	7127
pythoncore
Warning	4	warning C4005: 'WRITE_RESTRICTED' : macro redefinition
c:\program files\microsoft sdks\windows\v6.0a\include\winnt.h	7127
pythoncore
Warning	5	warning C4133: 'function' : incompatible types - from
'_typeobject *' to 'PyObject *'
c:\all\code\python-svn\modules\_collectionsmodule.c	1113	pythoncore
Warning	6	warning C4005: 'WRITE_RESTRICTED' : macro redefinition
c:\program files\microsoft sdks\windows\v6.0a\include\winnt.h	7127
pythoncore
Warning	7	warning C4018: '>' : signed/unsigned mismatch
c:\all\code\python-svn\modules\mmapmodule.c	693	pythoncore
Warning	8	warning C4018: '>' : signed/unsigned mismatch
c:\all\code\python-svn\modules\mmapmodule.c	834	pythoncore
Error	9	fatal error C1083: Cannot open include file: 'db.h': No such
file or directory	c:\all\code\python-svn\modules\_bsddb.c	90	_bsddb
Warning	10	warning LNK4075: ignoring '/EDITANDCONTINUE' due to
'/INCREMENTAL:NO' specification	_testcapimodule.obj	_testcapi
Warning	11	warning C4005: 'WRITE_RESTRICTED' : macro redefinition
c:\program files\microsoft sdks\windows\v6.0a\include\winnt.h	7127	_socket
Error	12	error C2373: 'inet_pton' : redefinition; different type
modifiers	c:\all\code\python-svn\modules\socketmodule.c	300	_socket
Error	13	error C2373: 'inet_ntop' : redefinition; different type
modifiers	c:\all\code\python-svn\modules\socketmodule.c	301	_socket
Error	14	error C2373: 'inet_pton' : redefinition; different type
modifiers	c:\all\code\python-svn\modules\socketmodule.c	5124	_socket
Error	15	error C2373: 'inet_ntop' : redefinition; different type
modifiers	c:\all\code\python-svn\modules\socketmodule.c	5139	_socket
Warning	16	warning LNK4075: ignoring '/EDITANDCONTINUE' due to
'/INCREMENTAL:NO' specification	winsound.obj	winsound
Warning	17	warning LNK4075: ignoring '/EDITANDCONTINUE' due to
'/INCREMENTAL:NO' specification	unicodedata.obj	unicodedata
Error	18	fatal error C1083: Cannot open include file: 'tcl.h': No such
file or directory	c:\all\code\python-svn\modules\_tkinter.c	66	_tkinter
Error	19	fatal error C1083: Cannot open include file: 'tcl.h': No such
file or directory	c:\all\code\python-svn\modules\tkappinit.c	16	_tkinter
Warning	20	warning LNK4075: ignoring '/EDITANDCONTINUE' due to
'/INCREMENTAL:NO' specification	selectmodule.obj	select
Error	21	fatal error C1083: Cannot open include file: 'sqlite3.h': No
such file or directory
c:\all\code\python-svn\modules\_sqlite\connection.h	33	_sqlite3
Error	22	fatal error C1083: Cannot open include file: 'sqlite3.h': No
such file or directory
c:\all\code\python-svn\modules\_sqlite\connection.h	33	_sqlite3
Error	23	fatal error C1083: Cannot open include file: 'sqlite3.h': No
such file or directory
c:\all\code\python-svn\modules\_sqlite\connection.h	33	_sqlite3
Error	24	fatal error C1083: Cannot open include file: 'sqlite3.h': No
such file or directory
c:\all\code\python-svn\modules\_sqlite\connection.h	33	_sqlite3
Error	25	fatal error C1083: Cannot open include file: 'sqlite3.h': No
such file or directory
c:\all\code\python-svn\modules\_sqlite\connection.h	33	_sqlite3
Error	26	fatal error C1083: Cannot open include file: 'sqlite3.h': No
such file or directory
c:\all\code\python-svn\modules\_sqlite\connection.h	33	_sqlite3
Error	27	fatal error C1083: Cannot open include file: 'sqlite3.h': No
such file or directory
c:\all\code\python-svn\modules\_sqlite\connection.h	33	_sqlite3
Warning	28	warning LNK4075: ignoring '/EDITANDCONTINUE' due to
'/INCREMENTAL:NO' specification	_msi.obj	_msi
Warning	29	warning LNK4075: ignoring '/EDITANDCONTINUE' due to
'/INCREMENTAL:NO' specification	_elementtree.obj	_elementtree
Warning	30	warning LNK4075: ignoring '/EDITANDCONTINUE' due to
'/INCREMENTAL:NO' specification	_ctypes_test.obj	_ctypes_test
Error	31	fatal error C1083: Cannot open include file: 'bzlib.h': No such
file or directory	c:\all\code\python-svn\modules\bz2module.c	12	bz2
Warning	32	warning C4005: 'WRITE_RESTRICTED' : macro redefinition
c:\program files\microsoft sdks\windows\v6.0a\include\winnt.h	7127	_ctypes
Warning	33	warning C4005: 'WRITE_RESTRICTED' : macro redefinition
c:\program files\microsoft sdks\windows\v6.0a\include\winnt.h	7127	_ctypes
Warning	34	warning LNK4075: ignoring '/EDITANDCONTINUE' due to
'/INCREMENTAL:NO' specification	pyexpat.obj	pyexpat
Warning	35	warning LNK4075: ignoring '/EDITANDCONTINUE' due to
'/INCREMENTAL:NO' specification	_ctypes.obj	_ctypes

</end of errors>


Are these solvable problems? Is there something I can do to help?

Thanks!
Swaroop
msg55892 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2007-09-13 15:39
This problems are surely solvable. However, I don't think they need to
be solved yet. Instead, before we make the next Python release, we
decide what VS version to build it with; if it's Orcas, then the
PCbuild directory will be updated to contain working project files.

Meanwhile, if you want to do something now, feel free to submit a
patch, either to PCbuild or PCbuild8. We will not apply that patch,
but it would be available for anybody who wants to experiment with
beta versions of Microsoft compilers.

Regards,
Martin
msg55906 - (view) Author: Swaroop (swaroopch) Date: 2007-09-14 02:08
Hi Martin,

I completely agree with you.

I would like to get it working but would need some guidance on the build
system... is there someone whose brains I can pick for this? :)

Also, we can mark this issue as 'not a bug'?
msg55908 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2007-09-14 05:59
Ok, I'm closing this as "won't fix" now. If you want to look for help,
ask on comp.lang.python. If you want some of the core developers to
resolve this, be patient - in about a year, it should be resolved. If
you ever come up with a patch, please submit this as a new report.
History
Date User Action Args
2007-09-14 06:53:56georg.brandlsetstatus: open -> closed
2007-09-14 05:59:16loewissettype: compile error -> enhancement
resolution: wont fix
messages: + msg55908
2007-09-14 02:08:48swaroopchsettype: compile error
messages: + msg55906
2007-09-13 15:39:38loewissetnosy: + loewis
messages: + msg55892
2007-09-13 14:46:04swaroopchsetversions: + Python 2.6, - Python 3.0
2007-09-13 14:35:43swaroopchcreate