classification
Title: Garbled chars in offending line of SyntaxError traceback
Type: behavior Stage:
Components: Interpreter Core Versions: Python 3.0
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: eopadoan, gvanrossum
Priority: normal Keywords:

Created on 2007-09-13 12:23 by eopadoan, last changed 2007-10-19 20:54 by gvanrossum. This issue is now closed.

Messages (4)
msg55888 - (view) Author: Eduardo Padoan (eopadoan) Date: 2007-09-13 12:23
Python 3.0a1 (py3k:58103, Sep 11 2007, 13:52:21) 
[GCC 4.1.2 (Ubuntu 4.1.2-0ubuntu4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> asd asd
  File "<stdin>", line 1
    P��
    ^
SyntaxError: invalid syntax
msg55917 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2007-09-14 19:48
I can't quite reproduce this, but I do see there's a problem with the
syntax error reporting:

Python 3.0a1 (py3k, Sep 12 2007, 12:23:06) 
[GCC 4.0.3 (Ubuntu 4.0.3-1ubuntu5)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> asd asd
  File "<stdin>", line 1
    >>>
msg56559 - (view) Author: Eduardo Padoan (eopadoan) Date: 2007-10-19 18:15
Can't reproduce this error anymore with revision 58472.
msg56563 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2007-10-19 20:54
There were some seriously broken things with exception reporting, most
of which I seem to have fixed.
History
Date User Action Args
2007-10-19 20:54:16gvanrossumsetstatus: open -> closed
resolution: fixed
messages: + msg56563
2007-10-19 18:15:50eopadoansetmessages: + msg56559
2007-09-18 12:26:25jafosetpriority: normal
2007-09-14 19:48:12gvanrossumsetnosy: + gvanrossum
messages: + msg55917
2007-09-13 12:24:05eopadoansettitle: Mangled chars in offending line of SyntaxError traceback -> Garbled chars in offending line of SyntaxError traceback
2007-09-13 12:23:09eopadoancreate