classification
Title: Float Plus Error
Type: Stage:
Components: Versions: Python 3.2, Python 2.7, Python 2.6, Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: lufengxa@gmail.com, mark.dickinson
Priority: normal Keywords:

Created on 2011-03-13 10:04 by lufengxa@gmail.com, last changed 2011-03-13 10:26 by mark.dickinson. This issue is now closed.

Messages (2)
msg130734 - (view) Author: Lu Feng (lufengxa@gmail.com) Date: 2011-03-13 10:04
Run 1.1 + 3.2, result is 4.300000000000001
And when Run [x * 0.1 for x in range(0, 10)], the result is
[0.0, 0.1, 0.2, 0.30000000000000004, 0.4, 0.5, 0.6000000000000001, 0.7000000000000001, 0.8, 0.9]
msg130735 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2011-03-13 10:26
See:

http://docs.python.org/tutorial/floatingpoint.html
History
Date User Action Args
2011-03-13 10:26:42mark.dickinsonsetstatus: open -> closed

nosy: + mark.dickinson
messages: + msg130735

resolution: not a bug
2011-03-13 10:04:34lufengxa@gmail.comcreate