classification
Title: Tools/demo, etc. are not installed
Type: Stage: resolved
Components: Demos and Tools, Installation Versions: Python 3.2
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: BreamoreBoy, eric.araujo, loewis, techtonik, terry.reedy
Priority: normal Keywords:

Created on 2011-03-04 05:37 by techtonik, last changed 2014-06-17 01:04 by terry.reedy. This issue is now closed.

Messages (7)
msg130025 - (view) Author: anatoly techtonik (techtonik) Date: 2011-03-04 05:36
Changelog for Python 3.2 contains this paragraph:
"- Issue #7962: The Demo directory is gone.  Most of the old and unmaintained demos have been removed, others integrated in documentation or a new Tools/demo subdirectory."

However, there is no "demo" inside of Tools directory in fresh install of Python 3.2 on Windows.
msg130028 - (view) Author: anatoly techtonik (techtonik) Date: 2011-03-04 05:40
See also #10502.
msg130094 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2011-03-05 00:31
I thought I posted this on another issue, but cannot find it.

My installed 3.2 Tools directory only has i8n, pynche, and scripts directories.
The 3.2 repository has 12 other directories in Tools that are missing from the installation.
msg130096 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2011-03-05 00:50
These directories aren't missing - they are simply not included. Each such inclusion should be preceded by an explicit request (preferably with some rationale).

Including the demo directory is fine with me.
msg130176 - (view) Author: anatoly techtonik (techtonik) Date: 2011-03-06 16:10
Explicit request for inclusion? What kind of bureaucracy are you up to?

Do you have a full list of missing or not included directories for various distributions? I'm sure many are curious to review them.
msg139889 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-07-05 16:07
> Explicit request for inclusion? What kind of bureaucracy are you up to?

This probably means: bug reports.

The Tools directory may or may not be included in UNIX tarballs, Mac OS X installers or Windows installers.  It is not documented anywhere that they should be, so I think this report is invalid.  The primary users of Tools are developers and contributors, not Python users in general; the part of Tools/demo that survived the 3.2 Demo Purge is not very useful, and could be moved to the docs or the wiki IMHO.
msg220764 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-06-16 21:08
msg139889 states "so I think this report is invalid" so I suggest we close this.
History
Date User Action Args
2014-06-17 01:04:26terry.reedysetstatus: open -> closed
resolution: not a bug
stage: resolved
2014-06-16 21:08:43BreamoreBoysetnosy: + BreamoreBoy
messages: + msg220764
2011-07-05 16:07:09eric.araujosettitle: No Tools/demo, etc, on Windows -> Tools/demo, etc. are not installed
nosy: + eric.araujo

messages: + msg139889

components: - Windows
2011-03-06 16:10:11techtoniksetmessages: + msg130176
2011-03-05 00:50:33loewissetmessages: + msg130096
2011-03-05 00:31:42terry.reedysettitle: No Tools/demo on Windows -> No Tools/demo, etc, on Windows
nosy: + loewis, terry.reedy

messages: + msg130094

components: + Installation, Windows
2011-03-04 05:40:06techtoniksetmessages: + msg130028
2011-03-04 05:37:00techtonikcreate