classification
Title: Fix distutils to carry configure's LIBS through to extension modules.
Type: enhancement Stage:
Components: Distutils Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: tarek Nosy List: eric.araujo, jszakmeister, tarek
Priority: normal Keywords: patch

Created on 2011-03-02 10:08 by jszakmeister, last changed 2011-03-27 22:03 by eric.araujo. This issue is now closed.

Files
File name Uploaded Description Edit
libs-to-extension.patch jszakmeister, 2011-03-02 10:08
Messages (5)
msg129863 - (view) Author: John Szakmeister (jszakmeister) * Date: 2011-03-02 10:08
This is a port of r301 from unladen swallow to the py3k-jit branch.

On the Mac, there was an extra '-framework CoreFoundation' that was being passed in python3 (maybe it wasn't there in Python 2.x?).  At any rate, I changed the logic to ignore anything that didn't start with a "-l" or end with a ".a".  Not sure if that's the best answer, or if we should allow -framework and friends to pass through.

I put this under distutils, but it's really targeted towards the py3k-jit branch... which hasn't been updated since June. :-(
msg129875 - (view) Author: John Szakmeister (jszakmeister) * Date: 2011-03-02 11:21
Looks like this should've been done against the py3k branch instead.  Looking at py3k, it's changed quite a bit since the last merge into py3k-jit.

Perhaps there is a better way to do this under py3k?  Or it's handled already?
msg131384 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-03-19 02:52
Thanks for the report and patch.  Has this bug been a problem for existing projects?  Would you have links?

> Looks like this should've been done against the py3k branch instead.
Yes, patches should apply to the py3k branch, or to distutils2.  More guidelines at http://wiki.python.org/moin/Distutils/FixingBugs

In this case, Tarek will have to decide whether this is a suitable bugfix for distutils or whether it’s for distutils2 only.  There is a feature freeze in distutils, so we try to change the code only to fix proved bugs, in the less pervasive way possible, and with regression tests.

> Perhaps there is a better way to do this under py3k?  Or it's handled already?
In the absence of a test (unit test, instructions to reproduce or script), it’s hard to tell.
msg132239 - (view) Author: John Szakmeister (jszakmeister) * Date: 2011-03-26 13:54
I'm gonna close this.  It was meant to help port some of the Unladen Swallow stuff... but I see that's effectively dead. :-(
msg132369 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-03-27 22:03
This looks like a real bug that could affect other projects than US, so it would be nice to get a test and fix IMO.
History
Date User Action Args
2011-03-27 22:03:46eric.araujosetmessages: + msg132369
2011-03-26 13:54:08jszakmeistersetstatus: open -> closed
resolution: not a bug
messages: + msg132239
2011-03-19 02:52:02eric.araujosetmessages: + msg131384
2011-03-02 11:21:54jszakmeistersetmessages: + msg129875
2011-03-02 10:08:24jszakmeistercreate