classification
Title: test_os fails
Type: Stage:
Components: Tests Versions: Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: giampaolo.rodola Nosy List: SilentGhost, giampaolo.rodola, neologix, pitrou, westley.martinez
Priority: normal Keywords:

Created on 2011-02-26 20:31 by westley.martinez, last changed 2011-02-28 23:37 by pitrou. This issue is now closed.

Files
File name Uploaded Description Edit
test_os westley.martinez, 2011-02-26 20:31 Output of test_os
Messages (9)
msg129589 - (view) Author: Westley Martínez (westley.martinez) * Date: 2011-02-26 20:31
test_invalid_offset failed on linux2.
msg129594 - (view) Author: SilentGhost (SilentGhost) * (Python triager) Date: 2011-02-26 21:19
Which revision are you trying with? I cannot reproduce this with r88656
msg129595 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-02-26 21:25
Errno 75 is EOVERFLOW here (Linux), which doesn't seem to be mentioned in sendfile's man page.
Can you describe your system? (CPU architecture, bitness, endianness, glibc/kernel version, etc.)
msg129596 - (view) Author: Westley Martínez (westley.martinez) * Date: 2011-02-26 21:31
rev 88657
Arch Linux 2.6.37 x86_64 with glibc2.6
64-bit, little endian
msg129597 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-02-26 21:35
> rev 88657
> Arch Linux 2.6.37 x86_64 with glibc2.6
> 64-bit, little endian

You are not running under a VM or something?
msg129600 - (view) Author: Westley Martínez (westley.martinez) * Date: 2011-02-26 21:43
> You are not running under a VM or something?

No
msg129603 - (view) Author: Charles-François Natali (neologix) * (Python committer) Date: 2011-02-26 22:21
> Errno 75 is EOVERFLOW here (Linux), which doesn't seem to be mentioned in sendfile's man page.
> Can you describe your system? (CPU architecture, bitness, endianness, glibc/kernel version, etc.)

Just checked the source code:
in fs/read_write.c:do_sendfile

 841         pos = *ppos;
 842         if (unlikely(pos + count > max)) {
 843                 retval = -EOVERFLOW;
 844                 if (pos >= max)
 845                         goto fput_out;
 846                 count = max - pos;
 847         }

and 

 869         if (*ppos > max)
 870                 retval = -EOVERFLOW;
msg129727 - (view) Author: Charles-François Natali (neologix) * (Python committer) Date: 2011-02-28 22:14
Alright, digging a little further, it's a kernel bug introduced by this commit:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=4a3956c790290efeb647bbb0c3a90476bb57800e

Note that this should only affect 64-bit systems (comparison between
long long int and unsigned long int). Also, it's only present since
2.6.37.

It has been fixed by this commit:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=cccb5a1e698535fa5a734ffe21c7061c97f8d8c5
msg129733 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-02-28 23:37
Thanks for the investigation, Charles-François. I'm closing as invalid, then.
History
Date User Action Args
2016-09-28 15:08:32berker.peksaglinkissue23520 superseder
2011-02-28 23:37:24pitrousetstatus: open -> closed

messages: + msg129733
resolution: not a bug
nosy: pitrou, giampaolo.rodola, SilentGhost, neologix, westley.martinez
2011-02-28 22:14:42neologixsetnosy: pitrou, giampaolo.rodola, SilentGhost, neologix, westley.martinez
messages: + msg129727
2011-02-26 22:21:45neologixsetnosy: + neologix
messages: + msg129603
2011-02-26 21:43:20westley.martinezsetnosy: pitrou, giampaolo.rodola, SilentGhost, westley.martinez
messages: + msg129600
2011-02-26 21:35:54pitrousetnosy: pitrou, giampaolo.rodola, SilentGhost, westley.martinez
messages: + msg129597
2011-02-26 21:31:40westley.martinezsetnosy: pitrou, giampaolo.rodola, SilentGhost, westley.martinez
messages: + msg129596
2011-02-26 21:25:10pitrousetassignee: giampaolo.rodola

messages: + msg129595
nosy: + giampaolo.rodola, pitrou
2011-02-26 21:19:41SilentGhostsetnosy: + SilentGhost
messages: + msg129594
2011-02-26 20:31:30westley.martinezcreate