classification
Title: No list of Python hg repositories
Type: behavior Stage:
Components: Documentation Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: blokeley, brett.cannon, docs@python, georg.brandl, loewis, pitrou, terry.reedy
Priority: normal Keywords: patch

Created on 2011-02-26 19:13 by blokeley, last changed 2011-03-06 18:38 by blokeley. This issue is now closed.

Files
File name Uploaded Description Edit
repo_locations.patch blokeley, 2011-02-26 19:13 Patch for hg_transition branch
Messages (6)
msg129585 - (view) Author: blokeley (blokeley) Date: 2011-02-26 19:13
Recently, I've logged a few issues on http://bugs.python.org/ and tried to submit patches where possible.

However, I have not been able to find any documentation that states where the hg repositories are. There are some under http://hg.python.org/ and some under http://code.python.org/hg

Please could the documentation somewhere list the official repos and what they are used for.

I have attached a patch to the devguide repo which probably has:
 * The wrong list of repos (I still don't know what the correct list is); and
 * The list in the wrong part of the documentation.

Nevertheless, I hope this helps.
msg129586 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-02-26 19:35
Thank you for the suggestion. We are actually starting our official transition to hg, which makes things a bit unstable.

The final URL (http://hg.python.org/cpython/) is currently a test repo, while the "usable for work right now" (http://code.python.org/hg/) repositories are temporary mirrors which will get dismantled once the transition is over. Meaning we probably want to adapt your patch a bit, once the dust settles ;)
msg129614 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2011-02-27 06:28
Just for the record: at the moment, Python's source code isn't maintained in Mercurial at all, but in subversion. Therefore, there are no official repos - it's no surprise you didn't find any documentation what they were.
msg130074 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2011-03-04 20:59
Conversion is underway today. Completion should be announced at least on the pydev list.
msg130151 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2011-03-06 09:52
Does this need any more action?
msg130183 - (view) Author: blokeley (blokeley) Date: 2011-03-06 18:38
Closed because the issue is solved by:

1. The devguide http://docs.python.org/devguide/ has a "Browse online" link that points to the correct repositories at http://hg.python.org/

2. Any attempt to access http://code.python.org/ redirects the user to the correct repositories above.
History
Date User Action Args
2011-03-06 18:38:00blokeleysetstatus: open -> closed

messages: + msg130183
resolution: fixed
nosy: loewis, brett.cannon, georg.brandl, terry.reedy, pitrou, docs@python, blokeley
2011-03-06 09:52:48georg.brandlsetnosy: + georg.brandl
messages: + msg130151
2011-03-04 20:59:56terry.reedysetnosy: + terry.reedy
messages: + msg130074
2011-02-27 06:28:36loewissetnosy: + loewis
messages: + msg129614
2011-02-26 19:35:13pitrousetnosy: + brett.cannon, pitrou
messages: + msg129586
2011-02-26 19:13:46blokeleycreate