classification
Title: NESTED WHILE CYCLES ERROR
Type: compile error Stage:
Components: Interpreter Core Versions: Python 3.2, Python 2.7, Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: alex, negius
Priority: normal Keywords:

Created on 2011-02-26 07:58 by negius, last changed 2011-02-26 08:03 by pitrou. This issue is now closed.

Files
File name Uploaded Description Edit
bug.py negius, 2011-02-26 07:58 error proof
Messages (2)
msg129506 - (view) Author: Dmitry Negius (negius) Date: 2011-02-26 07:58
Nested "while" cycles does not work. This make impossible to write a class of programs with nested while cycles.
msg129507 - (view) Author: Alex Gaynor (alex) * (Python committer) Date: 2011-02-26 08:00
This is invalid, there's no bug.  j doesn't get magically reinitialized to 0, in fact this code would do the same thing in any language I can think of.
History
Date User Action Args
2011-02-26 08:03:18pitrousetstatus: open -> closed
nosy: alex, negius
resolution: not a bug
2011-02-26 08:00:43alexsetnosy: + alex
messages: + msg129507
2011-02-26 07:58:40negiuscreate