Title: Reference Manual: "for statement" links to "break statement"
Type: Stage:
Components: Documentation, Windows Versions: Python 2.5
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: fdrake Nosy List: Martoon, fdrake, georg.brandl, jafo
Priority: normal Keywords:

Created on 2007-09-08 14:26 by Martoon, last changed 2007-09-18 07:16 by georg.brandl. This issue is now closed.

Messages (5)
msg55749 - (view) Author: Martoon (Martoon) Date: 2007-09-08 14:26
Error in the Windows distro documentation.  If you go to "for" or "for
statement" in the index, it brings you to the doc page for "The break
msg55956 - (view) Author: Sean Reifschneider (jafo) * (Python committer) Date: 2007-09-17 09:09
Can I get more information about how to reproduce this?  What is it you
do to get to this?  It sounds like you're talking about some HTML
documentation, but if I go to the current documentation in the Language
section, and click on the "for" section, I do get the for document:
msg55985 - (view) Author: Martoon (Martoon) Date: 2007-09-17 22:16
It's the Python25.chm file in the Windows distro.  I don't have a linux
box or a Mac, so I can't verify anything on them.  I suspect it's just
the .chm file in Windows.  If you open it, click the "Index" tab, and
select "for" or "for statement" from the keyword list, it jumps to the
"break statement" page in the html view pane.  I've since noticed that
it incorrectly links a lot of other keywords, so it appears to be a
global problem in the .chm file.  Everything in the nested view in the
"Contents" tab seems to link correctly.  It's just the keyword list in
the "Index" tab.
msg55986 - (view) Author: Sean Reifschneider (jafo) * (Python committer) Date: 2007-09-17 22:30
I don't know anything about the .chm file.  Fred: Do you know where this
comes from?
msg55990 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2007-09-18 07:16
There's nothing we can do here. There are three index entries for "for
statement", which link to the for, break and continue pages. They can't
be told apart, so we can't choose which one will be the first, the one
to display "for statement", and which will be those to display "[Link]".
Date User Action Args
2007-09-18 07:16:34georg.brandlsetstatus: open -> closed
resolution: wont fix
messages: + msg55990
nosy: + georg.brandl
2007-09-17 22:30:43jafosetstatus: pending -> open
assignee: jafo -> fdrake
messages: + msg55986
nosy: + fdrake
2007-09-17 22:16:59Martoonsetmessages: + msg55985
2007-09-17 09:09:45jafosetstatus: open -> pending
priority: normal
messages: + msg55956
assignee: jafo
nosy: + jafo
2007-09-08 14:26:46Martooncreate