classification
Title: Python installed from MSI doesn't work
Type: Stage:
Components: IDLE, Windows Versions: Python 3.2
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: BWY, Matthew.Funke, brian.curtin, loewis, skrah
Priority: normal Keywords: 3.2regression

Created on 2011-02-22 15:41 by Matthew.Funke, last changed 2011-02-23 18:52 by loewis. This issue is now closed.

Messages (12)
msg129088 - (view) Author: Matthew Funke (Matthew.Funke) Date: 2011-02-22 15:41
I uninstalled Python 3.1.3 and installed the 32-bit version of Python 3.2 on my 64-bit Win7 box.  (My favorite IDE requires the 32-bit version.)  trying to run IDLE crashes; running C:\python32\python.exe returns this error:

Fatal Python error: Py_Initialize: unable to load the file system codec
LookupError: no codec search functions registered: can't find encoding

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

I tried Googling the error, but couldn't find much help for it.  Thoughts?
msg129129 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2011-02-22 21:11
Can anybody reproduce this?
msg129130 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2011-02-22 21:20
It works fine for me. Just did a 32-bit Python 3.2 install on a Windows 7 64-bit machine and IDLE works.
msg129134 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2011-02-22 21:44
Matthew: please run "python -v", and attach any output it makes to this report.
msg129136 - (view) Author: Matthew Funke (Matthew.Funke) Date: 2011-02-22 21:51
Here's the output, in its entirety:

-------------------------

C:\Python32>python -v
# installing zipimport hook
import zipimport # builtin
# installed zipimport hook
Fatal Python error: Py_Initialize: unable to load the file system codec
LookupError: no codec search functions registered: can't find encoding

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.
msg129137 - (view) Author: Matthew Funke (Matthew.Funke) Date: 2011-02-22 21:59
I also tried uninstalling, re-downloading the MSI, and re-installing, but no joy.  Thank you for any insight you can lend.
msg129158 - (view) Author: Bartosz (BWY) Date: 2011-02-23 07:55
I've got the same situation. Windows 7 (32bit) python-3.2.msi installations puts through, but when I try to lunch python appears error :

Fatal Python error: Py_Initialize: unable to load the file system codec
LookupError: no codec search functions registered: can't find encoding
msg129165 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2011-02-23 10:42
Works fine for me (Windows 7, 64-bit, 32-bit Python-3.2). I do have the
plain US English version. Do you have localized versions?
msg129191 - (view) Author: Bartosz (BWY) Date: 2011-02-23 13:30
I've got English version too. Python is 32 bit and operating system is also 32 bit.
msg129194 - (view) Author: Bartosz (BWY) Date: 2011-02-23 13:42
I have found a problem and sollution:

previously I have used Python 2.x and when I removed that version and next installed Python32,  PYTHONPATH in system variabled indicated still to Python2.x. Removing all python paths to old version solved the problem.
msg129204 - (view) Author: Matthew Funke (Matthew.Funke) Date: 2011-02-23 15:01
Changing the environment variables did the trick!  Thank you very much!
msg129219 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2011-02-23 18:52
Ok, closing this as "invalid" then - it's not a bug in the installer, but a misconfiguration of the local system. Thanks to Bartosz for the analysis!
History
Date User Action Args
2012-10-24 00:36:25roger.serwylinkissue9890 superseder
2011-02-23 18:52:45loewissetstatus: open -> closed

messages: + msg129219
resolution: not a bug
nosy: loewis, brian.curtin, skrah, Matthew.Funke, BWY
2011-02-23 15:01:39Matthew.Funkesetnosy: loewis, brian.curtin, skrah, Matthew.Funke, BWY
messages: + msg129204
2011-02-23 13:42:04BWYsetnosy: loewis, brian.curtin, skrah, Matthew.Funke, BWY
messages: + msg129194
2011-02-23 13:30:46BWYsetnosy: loewis, brian.curtin, skrah, Matthew.Funke, BWY
messages: + msg129191
2011-02-23 10:42:23skrahsetnosy: + skrah
messages: + msg129165
2011-02-23 07:55:44BWYsetnosy: + BWY
messages: + msg129158
2011-02-23 07:23:50georg.brandlsetkeywords: + 3.2regression
2011-02-22 21:59:39Matthew.Funkesetmessages: + msg129137
2011-02-22 21:51:26Matthew.Funkesetmessages: + msg129136
2011-02-22 21:44:23loewissetmessages: + msg129134
2011-02-22 21:20:09brian.curtinsetmessages: + msg129130
2011-02-22 21:11:59loewissetmessages: + msg129129
2011-02-22 15:50:48brian.curtinsetnosy: + loewis, brian.curtin
2011-02-22 15:41:58Matthew.Funkecreate