classification
Title: Python Programming FAQ should be updated for Python 2.4
Type: Stage:
Components: Documentation Versions: Python 2.4
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: akuchling Nosy List: akuchling, georg.brandl, hoffman, jafo, rhettinger, skip.montanaro, terry.reedy
Priority: normal Keywords:

Created on 2005-02-09 17:17 by hoffman, last changed 2007-08-23 21:11 by georg.brandl. This issue is now closed.

Messages (10)
msg24224 - (view) Author: Michael Hoffman (hoffman) Date: 2005-02-09 17:17
For example:

* "1.4.3 How do I iterate over a sequence in reverse
order?" should use reversed()
* "1.4.4   How do you remove duplicates from a list?"
should use set()
* "1.5.2   I want to do a complicated sort: can you do
a Schwartzian Transform in Python?" should use sort(key=)
* section 1.6 should use new-style classes
msg24225 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2005-02-16 22:49
Logged In: YES 
user_id=593130

I believe the FAQs are only maintained at www.python.org 
and not at SourceForge.  If so, you should email your 
comments to webmaster@python.org and/or 
docs@python.org.

I strongly urge you to work your comments up into a set of 
specific patches (in text form).  In other words, give a 
specific suggested text to replace or augment the old one.  
Since there is no paid editor, this will make changes much 
easier and therefore more likely sooner.
msg24226 - (view) Author: Sean Reifschneider (jafo) * (Python committer) Date: 2005-04-20 03:31
Logged In: YES 
user_id=81797

I've submitted this to the webmaster@python.org list for
pursual.  Michael Hoffman: If you can make a patch of the
suggested changes, to help the process along.  I'm
considering it closed here, please let me know if you think
is inappropriate?
msg24227 - (view) Author: Michael Hoffman (hoffman) Date: 2005-04-20 08:06
Logged In: YES 
user_id=987664

That does not seem inappropriate. I unfortunately do not
have time to do a real patch at this point. But this might
be an excellent way for someone on comp.lang.python to help out.
msg24228 - (view) Author: Skip Montanaro (skip.montanaro) * (Python triager) Date: 2005-04-20 12:59
Logged In: YES 
user_id=44345

Let's leave this open.  It is a documentation bug/feature,
so I think it was
submitted to the correct place.

Skip
msg24229 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2005-04-20 18:55
Logged In: YES 
user_id=593130

MH: by "a set of specific patches (in text form)" I meant an ascii 
text file with each item indicating a specific slice or location in 
the existing doc (possibly by quotation) and a suggested new text 
to insert.  The site/doc maintainers have said that this is enough: 
if they agree with the new text, they will add the latex markup and 
produce the 'real patch'.  Judging from your writing here, you 
seem quite capable of producing literate (ascii-text) sentences.

SM: I currently disagree with this being reopened.  1) The items 
may need updating (like much library code) but this does not 
make them wrong (buggy).  2) The "Programmer's FAQ' is not 
part of the official doc defining the language and implementation 
nor, last I knew, is it part of the distribution.  To me, it is one of 
hundred's of supplementary web pages, including the PEPs, 
some at python.org and some elsewhere. 3) the site gives its own 
address, not here, for submitting suggestions, like this, for 
improvememt.
msg24230 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2005-04-20 19:12
Logged In: YES 
user_id=80475

Andrew, do you have a preference as to whether this is kept
on SF or done through pydotorg?
msg24231 - (view) Author: Skip Montanaro (skip.montanaro) * (Python triager) Date: 2005-04-20 19:22
Logged In: YES 
user_id=44345

In the absence of some other place to track this or a better
category ("website"?) this seems as good a place as any
to record the request.  If we decide it's not a bug (advising
people to use old solutions is not obviously a bug), then sure,
close with "won't fix" or "invalid".  Let's not simply lose the
request though.
msg24232 - (view) Author: Skip Montanaro (skip.montanaro) * (Python triager) Date: 2005-04-20 20:04
Logged In: YES 
user_id=44345

(Last comment crossed paths with change to akuchling -
restoring)
msg55213 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2007-08-23 21:11
Fixed in my pydotorg tree, will commit as soon as I find out how :)
History
Date User Action Args
2007-08-23 21:11:45georg.brandlsetstatus: open -> closed
nosy: + georg.brandl
resolution: fixed
messages: + msg55213
2005-02-09 17:17:51hoffmancreate