classification
Title: Search index is messed up after partial rebuilding
Type: Stage:
Components: Documentation tools (Sphinx) Versions:
process
Status: closed Resolution: accepted
Dependencies: Superseder:
Assigned To: Nosy List: georg.brandl, lars.gustaebel
Priority: normal Keywords: patch

Created on 2007-09-06 13:11 by lars.gustaebel, last changed 2007-09-06 14:13 by georg.brandl. This issue is now closed.

Files
File name Uploaded Description Edit
sphinx-index.diff lars.gustaebel, 2007-09-06 13:11
Messages (2)
msg55689 - (view) Author: Lars Gustäbel (lars.gustaebel) * (Python committer) Date: 2007-09-06 13:11
When rebuilding parts of the documentation the search index is emptied.
The problem is that the extensions are not stripped from the filenames
that are given to IndexBuilder.prune() method.

Therefore, the Search widget on http://docs.python.org/dev/3.0/ produces
no results.
msg55693 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2007-09-06 14:13
Lars Gustäbel schrieb:
> New submission from Lars Gustäbel:
> 
> When rebuilding parts of the documentation the search index is emptied.
> The problem is that the extensions are not stripped from the filenames
> that are given to IndexBuilder.prune() method.
> 
> Therefore, the Search widget on http://docs.python.org/dev/3.0/ produces
> no results.

Thanks, fixed in rev. 58009!

Georg
History
Date User Action Args
2007-09-06 14:13:28georg.brandlsetstatus: open -> closed
nosy: + georg.brandl
messages: + msg55693
resolution: accepted
2007-09-06 13:11:26lars.gustaebelcreate