classification
Title: SVN credentials can't be provided to easy_install
Type: behavior Stage: resolved
Components: Installation Versions: Python 3.3
process
Status: closed Resolution: later
Dependencies: Superseder:
Assigned To: Nosy List: r.david.murray, tarek, yegor256
Priority: normal Keywords:

Created on 2011-02-08 11:46 by yegor256, last changed 2011-02-08 13:29 by r.david.murray. This issue is now closed.

Messages (2)
msg128173 - (view) Author: Yegor Bugayenko (yegor256) Date: 2011-02-08 11:46
I'm trying to install Python EGG with `easy_install`, providing a URL of Subversion repository, where sources are hosted:

    $ easy_install svn://user:secret@svn.example.com/repo/trunk/my-egg
    Authentication realm: <svn://svn.example.com:3690> repo
    Password for 'me':
    
The problem is that the repository is password protected. How can I provide the desired username/password to `easy_install`?

Everything works fine when I'm using `http://` protocol instead of `svn://`
msg128178 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2011-02-08 13:29
easy_install is not part of python.  Please report this to the easy_install bug tracker instead.
History
Date User Action Args
2011-02-08 13:29:36r.david.murraysetstatus: open -> closed

nosy: + tarek, r.david.murray
messages: + msg128178

resolution: later
stage: resolved
2011-02-08 11:46:46yegor256create