classification
Title: Python 2.7.1 Idle traceback on OS X (10.6.6)
Type: behavior Stage: resolved
Components: IDLE Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: ned.deily Nosy List: David.Meier, ned.deily, r.david.murray
Priority: normal Keywords:

Created on 2011-01-29 22:21 by David.Meier, last changed 2011-01-31 17:41 by David.Meier. This issue is now closed.

Messages (7)
msg127492 - (view) Author: David Meier (David.Meier) Date: 2011-01-29 22:21
After IDLE launches I select 'File->Open' browse to a blank .py file, when I select the particular file I get the segfault below...

silverbox:~ user$ (idle&)
silverbox:~ user$ Traceback (most recent call last):
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/idlelib/run.py", line 93, in main
    seq, request = rpc.request_queue.get(block=True, timeout=0.05)
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/Queue.py", line 177, in get
    self.not_empty.wait(remaining)
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/threading.py", line 257, in wait
    _sleep(delay)
TypeError: 'int' object is not callable
msg127493 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2011-01-29 22:35
Does it matter what the contents of the file are, i.e. what do you mean by a "blank .py" file?  I am not able to reproduce that problem.

Be aware that, because of problems with the Apple-suppled Cocoa Tk 8.5 in OS X 10.6, the 2.7.1 IDLE from the 10.6-only 64-bit/32-bit installer from python.org is problematic.  In the interim, we recommend you use 2.7.1 IDLE from the 10.3-through-10.6 32-bit-only installer.
msg127495 - (view) Author: David Meier (David.Meier) Date: 2011-01-29 23:04
It doesn't matter what's in the file itself.  By 'blank' I mean, literally, an empty file (i.e. `touch file.py`).

You are correct that this was installed from the 10.6 specific 2.7.1, I will try to install from the other version.  Is there a recommended uninstallation before trying this?
msg127497 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2011-01-29 23:09
To uninstall, you can do the following:

sudo rm -rf /Library/Frameworks/Python.framework/Versions/2.7
sudo rm -rf /Applications/"Python 2.7"

If you've installed any site-packages, you would need to re-install them.
msg127539 - (view) Author: David Meier (David.Meier) Date: 2011-01-30 14:44
Removing the 10.6 specific Python 2.7.1 installation (with the instructions provided by Ned) and reinstalling the 10.3-10.6 32bit installation fixed the aforementioned segfault.  Thanks for the information, however, I do think it should be noted on the download page that there are problems with the 10.6 32/64-bit version and it is safer to go the 32-bit only installer unless there is a specific need.  I did not see any caveats mentioned when I went to download it.
msg127629 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2011-01-31 17:34
FYI, a python traceback is not a segfault.  Nor is it a 'crash' in the sense we use in this tracker.

The warning has been added to the download page, though there is discussion about whether or not it should be more prominent.
msg127631 - (view) Author: David Meier (David.Meier) Date: 2011-01-31 17:41
Sorry that what I had pasted in does not show a segfault, however if you run it as `idle` (i.e. no `(idle&)) the command line reports a generic "Segmentation fault" with no traceback.  So, yes, it is a segmentation fault - but I figured it was more useful if you had the traceback when running it that way.  Whether or not the two are related I do not know.
History
Date User Action Args
2011-01-31 17:41:56David.Meiersetnosy: ned.deily, r.david.murray, David.Meier
messages: + msg127631
2011-01-31 17:34:25r.david.murraysetstatus: open -> closed

type: crash -> behavior

nosy: + r.david.murray
messages: + msg127629
resolution: not a bug
stage: resolved
2011-01-30 14:44:08David.Meiersetmessages: + msg127539
2011-01-29 23:09:06ned.deilysetmessages: + msg127497
2011-01-29 23:04:47David.Meiersetmessages: + msg127495
2011-01-29 22:35:40ned.deilysetmessages: + msg127493
2011-01-29 22:28:45georg.brandlsetassignee: ned.deily

nosy: + ned.deily
title: Python 2.7.1 Idle Segmentation Fault OS X (10.6.6) -> Python 2.7.1 Idle traceback on OS X (10.6.6)
2011-01-29 22:21:42David.Meiercreate