classification
Title: dist directory not created when running sdist command
Type: behavior Stage:
Components: Distutils2 Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: tarek Nosy List: eric.araujo, kelsey.hightower, tarek
Priority: normal Keywords:

Created on 2011-01-29 11:26 by kelsey.hightower, last changed 2011-01-29 19:47 by kelsey.hightower. This issue is now closed.

Messages (5)
msg127401 - (view) Author: Kelsey (kelsey.hightower) Date: 2011-01-29 11:26
When trying to create a source distribution, I get the following error and no stack trace:


[openpython:yamlconfig]$ /opt/OpenPython-2.7.1/bin/python -m distutils2.run sdist
WARNING:root:warning: no files found matching 's'
WARNING:root:warning: no files found matching 'e'
WARNING:root:warning: no files found matching 't'
WARNING:root:warning: no files found matching 'u'
WARNING:root:warning: no files found matching 'p'
WARNING:root:warning: no files found matching '.'
WARNING:root:warning: no files found matching 'p'
WARNING:root:warning: no files found matching 'y'
error: dist/yamlconfig-0.3.1.tar.gz: No such file or directory

Not sure what all the WARNINGs are for, will file a separate issue for those.
msg127404 - (view) Author: Kelsey (kelsey.hightower) Date: 2011-01-29 11:32
Link to patch:
https://bitbucket.org/khightower/distutils2/changeset/6ef86fa5236b
msg127452 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-01-29 18:08
The warnings mean that some code is iterating over the string 'setup.py' instead of a list like ['setup.py'].  This message comes from the manifest module, but I don’t know more.

Regarding the bug and proposed patch, I wonder.  This was not needed previously, so why is it now?
msg127477 - (view) Author: Kelsey (kelsey.hightower) Date: 2011-01-29 19:39
This could be my mistake. . I think an early attempt at patching Issue 11045, I disabled os.makedirs(archive_dir) in shutil. I am going to retest
msg127479 - (view) Author: Kelsey (kelsey.hightower) Date: 2011-01-29 19:47
I have retested; this issue was related to a bug I introduced in shutil (fixed now, and patch sent upstream)
History
Date User Action Args
2011-01-29 19:47:44kelsey.hightowersetstatus: open -> closed

messages: + msg127479
resolution: not a bug
nosy: tarek, eric.araujo, kelsey.hightower
2011-01-29 19:39:07kelsey.hightowersetnosy: tarek, eric.araujo, kelsey.hightower
messages: + msg127477
2011-01-29 18:08:43eric.araujosetnosy: tarek, eric.araujo, kelsey.hightower
messages: + msg127452
2011-01-29 11:32:36kelsey.hightowersetnosy: tarek, eric.araujo, kelsey.hightower
messages: + msg127404
2011-01-29 11:26:59kelsey.hightowercreate