classification
Title: State of PEP 382 or How does distutils2 handle namespaces?
Type: Stage: resolved
Components: Distutils2 Versions: 3rd party
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: eric.araujo Nosy List: eric.araujo, loewis, lukasz.langa, sdouche, tarek
Priority: normal Keywords:

Created on 2011-01-28 10:34 by sdouche, last changed 2011-09-19 14:05 by eric.araujo. This issue is now closed.

Messages (10)
msg127274 - (view) Author: Sebastien Douche (sdouche) Date: 2011-01-28 10:34
Namespace is very useful. In my company, we use a root namespace (sact.*) and a sub-namespace for each big project (sact.nevrax.*, sact.storage.*).
msg127345 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2011-01-28 21:10
See PEP 382: http://www.python.org/dev/peps/pep-0382/
msg127389 - (view) Author: Łukasz Langa (lukasz.langa) * (Python committer) Date: 2011-01-29 09:34
Martin, could you shed some light on the state of that PEP?
msg127428 - (view) Author: Sebastien Douche (sdouche) Date: 2011-01-29 15:10
Thanks Martin for the response, but I cannot understand how implement it after reading the PEP.
msg127429 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-01-29 15:14
Hi Sébastien.  How does d2 handle namespaces?  It does not, because such a thing does not exist yet.  We don’t support setuptools’ namespace packages, but wait for the cleaned-up standardization thanks to to PEP 382.  That PEP hasn’t reached consensus yet, so it’s too early to implement it.  If that answers your question, I think I’ll close this bug: There’s nothing we can do now, and when PEP 382 is accepted, support will be added to d2.
msg127430 - (view) Author: Tarek Ziadé (tarek) * (Python committer) Date: 2011-01-29 15:15
Yes me neither. The PEP is hard to understand, maybe a pseudo-code example could shed some light
msg127431 - (view) Author: Tarek Ziadé (tarek) * (Python committer) Date: 2011-01-29 15:18
Eric: the PEP was accepted already IIRC, and its status is not up-to-date.

So it's just a matter of adding the implementation now. This bug can be a placeholder for its implementation if no other bug was opened for this yet
msg127443 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-01-29 17:17
This message makes me think it is not accepted: http://mail.python.org/pipermail/python-dev/2010-May/100457.html
msg127506 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2011-01-30 02:06
> Martin, could you shed some light on the state of that PEP?

It's implemented in a branch, and will likely be included in Python 3.3.
msg144275 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-09-19 14:05
As a question about a proposed PEP which is not accepted and has a competitor (see python-threads about PEP 402), this is not really a bug report.  Closing.
History
Date User Action Args
2011-09-19 14:05:01eric.araujosetstatus: open -> closed
title: State of PEP 382 or How does distutils2 handle namespaces? -> State of PEP 382 or How does distutils2 handle namespaces?
messages: + msg144275

assignee: tarek -> eric.araujo
resolution: not a bug
stage: resolved
2011-01-30 02:06:55loewissetnosy: loewis, tarek, eric.araujo, sdouche, lukasz.langa
messages: + msg127506
title: Implementing PEP 382 -> State of PEP 382 or How does distutils2 handle namespaces?
2011-01-29 17:17:42eric.araujosetnosy: loewis, tarek, eric.araujo, sdouche, lukasz.langa
messages: + msg127443
2011-01-29 15:19:41tareksetnosy: loewis, tarek, eric.araujo, sdouche, lukasz.langa
title: How does distutils2 handle namespaces? -> Implementing PEP 382
2011-01-29 15:18:31tareksetnosy: loewis, tarek, eric.araujo, sdouche, lukasz.langa
messages: + msg127431
2011-01-29 15:15:28tareksetnosy: loewis, tarek, eric.araujo, sdouche, lukasz.langa
messages: + msg127430
2011-01-29 15:14:29eric.araujosetnosy: loewis, tarek, eric.araujo, sdouche, lukasz.langa
title: State of PEP 382 or How does distutils2 handle namespaces? -> How does distutils2 handle namespaces?
messages: + msg127429
versions: + 3rd party
2011-01-29 15:10:16sdouchesetnosy: loewis, tarek, eric.araujo, sdouche, lukasz.langa
messages: + msg127428
2011-01-29 09:34:25lukasz.langasetnosy: + lukasz.langa

messages: + msg127389
title: How distutils2 handle namespaces -> State of PEP 382 or How does distutils2 handle namespaces?
2011-01-28 21:10:38loewissetnosy: + loewis
messages: + msg127345
2011-01-28 10:34:50sdouchecreate