classification
Title: Typo in dummy_threading documentation
Type: Stage:
Components: Documentation Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: dthomasset, loewis
Priority: normal Keywords:

Created on 2007-09-04 21:29 by dthomasset, last changed 2007-09-04 21:43 by dthomasset. This issue is now closed.

Files
File name Uploaded Description Edit
unnamed dthomasset, 2007-09-04 21:43
Messages (3)
msg55645 - (view) Author: Dan Thomasset (dthomasset) Date: 2007-09-04 21:29
I believe that "thread" be "threading" in the line "...imported when the
thread module is not provided..."?

From http://docs.python.org/lib/module-dummythreading.html
msg55647 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2007-09-04 21:35
Why do you think so? The documentation is correct as it stands;
dummy_threading should be used when thread is not present, not when
threading is not present (as threading will always be present, it just
won't import when thread is not present).
msg55648 - (view) Author: Dan Thomasset (dthomasset) Date: 2007-09-04 21:43
Ahh, my mistake then.  I misunderstood what was going on.

Thanks,
 Dan

On 9/4/07, Martin v. Löwis <report@bugs.python.org> wrote:
>
>
> Martin v. Löwis added the comment:
>
> Why do you think so? The documentation is correct as it stands;
> dummy_threading should be used when thread is not present, not when
> threading is not present (as threading will always be present, it just
> won't import when thread is not present).
>
> ----------
> nosy: +loewis
> resolution:  -> invalid
> status: open -> closed
>
> __________________________________
> Tracker <report@bugs.python.org>
> <http://bugs.python.org/issue1103>
> __________________________________
>
History
Date User Action Args
2007-09-04 21:43:59dthomassetsetfiles: + unnamed
messages: + msg55648
2007-09-04 21:35:29loewissetstatus: open -> closed
resolution: not a bug
messages: + msg55647
nosy: + loewis
2007-09-04 21:29:35dthomassetcreate