classification
Title: mailbox.py open() calls don't set encoding
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.1
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Mailbox module should use binary I/O, not text I/O
View: 9124
Assigned To: Nosy List: r.david.murray, sdaoden
Priority: normal Keywords:

Created on 2011-01-24 14:23 by sdaoden, last changed 2011-01-24 14:58 by r.david.murray. This issue is now closed.

Messages (2)
msg126930 - (view) Author: Steffen Daode Nurpmeso (sdaoden) Date: 2011-01-24 14:23
I'm using the en_GB.UTF-8 locale and thus the entire I/O layer defaults to use UTF-8 encoding.  Perfect.
The problem is that mailboxes are *not* and *never* in UTF-8, generally speaking, according to RFC mail standards!

So i suggest that mailbox.py either offers additional 'encoding="latin1"' constructor arguments or always uses "latin1" in open() calls.
This suffices to make mailbox.py usable -
i.e., the mailbox will be loaded/saved without causing encoder errors, and email.py will behave correctly according to message *content* anyway!

P.S.: i am far from being a Python(1) freak and feel a bit lost on *.python.org, so i might have blown the wrong whistles too load.
Sorry, if this is the case.
Thanks for python(1), it's damn slow and i love C and Perl.  ;-)
msg126931 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2011-01-24 14:58
Issue 9124 addresses the underlying problem here, so I'm closing this as a duplicate.
History
Date User Action Args
2011-01-24 14:58:43r.david.murraysetstatus: open -> closed

superseder: Mailbox module should use binary I/O, not text I/O

nosy: + r.david.murray
messages: + msg126931
resolution: duplicate
stage: resolved
2011-01-24 14:23:45sdaodencreate