classification
Title: dev task of documenting undocumented APIs
Type: enhancement Stage: needs patch
Components: Devguide, Documentation Versions: Python 3.5
process
Status: closed Resolution: out of date
Dependencies: 10224 Superseder:
Assigned To: docs@python Nosy List: BreamoreBoy, brett.cannon, docs@python, eric.araujo, eric.snow, ezio.melotti, willingc
Priority: low Keywords:

Created on 2011-01-20 23:33 by brett.cannon, last changed 2016-07-22 19:50 by brett.cannon. This issue is now closed.

Messages (5)
msg126662 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2011-01-20 23:33
Once the docs are built using Python 3, then the coverage results can be used by people wanting to contribute as something to do. Should also mention in the task that some APIs should probably be private: http://mail.python.org/pipermail/python-dev/2010-November/105476.html .
msg242453 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2015-05-03 06:18
Where do we stand on this as #10224 has been closed as "out of date"?
msg242487 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2015-05-03 15:36
The issue is still valid and waiting for someone to submit a patch to the devguide.
msg242490 - (view) Author: Carol Willing (willingc) * (Python committer) Date: 2015-05-03 16:14
Add key points from linked email in msg126662 to documentation section of the devguide. 

* provide developers guidance on how to document undocumented APIs
* when and how to use __all__
* include rules from the linked email
* highlight "do no harm" to existing users as discussed in email
msg271018 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2016-07-22 19:50
Moved to https://github.com/python/devguide/issues/10
History
Date User Action Args
2016-07-22 19:50:50brett.cannonsetstatus: open -> closed
resolution: out of date
messages: + msg271018
2015-05-03 16:14:46willingcsetnosy: + ezio.melotti, willingc, docs@python
messages: + msg242490

assignee: docs@python
components: + Devguide
2015-05-03 15:36:31brett.cannonsetmessages: + msg242487
2015-05-03 06:18:15BreamoreBoysetnosy: + BreamoreBoy
messages: + msg242453
2014-04-14 19:33:59eric.araujosetnosy: + eric.araujo

versions: + Python 3.5, - Python 3.3
2013-02-16 20:30:09eric.snowsetnosy: + eric.snow
2013-01-11 20:46:37brett.cannonsetassignee: brett.cannon -> (no value)
2011-01-20 23:34:37brett.cannonsetdependencies: + Build 3.x documentation using python3.x
2011-01-20 23:33:40brett.cannoncreate