classification
Title: ImportError module attribute
Type: enhancement Stage: resolved
Components: Versions:
process
Status: closed Resolution: duplicate
Dependencies: Superseder: ImportError needs attributes for module and file name
View: 1559549
Assigned To: Nosy List: brian.curtin, techtonik
Priority: normal Keywords:

Created on 2011-01-07 16:26 by techtonik, last changed 2011-01-07 17:04 by techtonik. This issue is now closed.

Messages (3)
msg125656 - (view) Author: anatoly techtonik (techtonik) Date: 2011-01-07 16:26
Need ImportError.module attribute to get the name of failed import. Right now it requires parsing ImportError.args that is presented in form "('No module named zqwer',)" that is not pythonic.
msg125658 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2011-01-07 16:28
Duplicate of #1559549
msg125659 - (view) Author: anatoly techtonik (techtonik) Date: 2011-01-07 17:04
Thanks for the pointer. I couldn't find it myself.
History
Date User Action Args
2011-01-07 17:04:22techtoniksetnosy: techtonik, brian.curtin
messages: + msg125659
2011-01-07 16:28:22brian.curtinsetstatus: open -> closed

superseder: ImportError needs attributes for module and file name

nosy: + brian.curtin
messages: + msg125658
resolution: duplicate
stage: resolved
2011-01-07 16:26:23techtonikcreate