This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Title: Python 2.7 x86 IDLE fails to run in Windows 7
Type: behavior Stage:
Components: IDLE, Windows Versions: Python 2.7
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: brian.curtin, excubated, loewis, roger.serwy, terry.reedy
Priority: normal Keywords:

Created on 2011-01-05 10:41 by excubated, last changed 2022-04-11 14:57 by admin. This issue is now closed.

File name Uploaded Description Edit
python test halt.jpg excubated, 2011-01-19 10:18 Screenshot of the command line window with the test running (or not running)
Messages (15)
msg125415 - (view) Author: Peter Heiberg (excubated) Date: 2011-01-05 10:41
I recently installed Win7 on my laptop, and installed the x86 Python 2.7 package.  IDLE fails to even start, and shows nothing but a process in task manager.  I've tried compatibility modes both to Vista and XPSP2, with no luck.

I ran 2.7 x86 on the same laptop in XPSP2, and I am also able to run 2.7 x86 on another computer using the exact same version of Win7.

Command line works fine, by the way.
msg125430 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2011-01-05 16:18
Can you start IDLE from the command line and see if there is any output?

c:\python27\python.exe -m idlelib.idle
msg125448 - (view) Author: Peter Heiberg (excubated) Date: 2011-01-05 18:25
The command line opens, but displays nothing but the white flashing underscore..
msg125450 - (view) Author: Peter Heiberg (excubated) Date: 2011-01-05 18:27
I'd like to add that I had the exact same problem on my other laptop running Win7 x64, but the same laptop (as mentioned earlier) now runs Win7 x86 and IDLE works fine on that.
msg125457 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2011-01-05 19:22
Have you confirmed that the IDLE window isn't just opened behind another window or possibly minimized? I don't know the cause of this, but a coworker has seen a few times where IDLE will open but it isn't the main focused window (hiding behind a full-screen browser, for instance).

I haven't been able to reproduce this on any of the versions I have here, and did a fresh install of 2.7.1 where it also didn't happen. I'm on Windows 7 x64.
msg125459 - (view) Author: Peter Heiberg (excubated) Date: 2011-01-05 19:31
The IDLE window doesn't open, the taskbar shows no icons and IDLE does not show up under Task Manager's Application tab..

Also, whenever I open an instance of IDLE, two instances of the .exe shows up under the Processes tab:

one instance is completely inactive on CPU use, and uses 9788K of memory,
the other instance runs at 1-2% CPU with a constant 5892K memory usage.
msg125460 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2011-01-05 19:37
Weird. I'm not sure what could be happening here, and I'm not an IDLE user so I don't really have anything else to try out here.

I noticed your email address is for what I think is a Norwegian domain. Is your Windows install set to be a language other than English? It may be possible that something on startup isn't being encoded/decoded properly. Not really sure...
msg125464 - (view) Author: Peter Heiberg (excubated) Date: 2011-01-05 20:06
I am running the EN-US version of Win7, with Norwegian regional and keyboard settings.  Tried changing everything to EN-US, with no change in results.  Also tried deactivating visual themes and desktop composition for the .exe.

What text editor do you personally prefer?  I have tried setting up Notepad++ for the job, but I can't seem to get the "Run" function to work properly..
msg125465 - (view) Author: Peter Heiberg (excubated) Date: 2011-01-05 20:23
Hey, progress!  I ran python.exe, typed "import idlelib.idle", pressed enter - same blinking underscore as before.  Then i pressed Ctrl+C, and WHOA, python.exe prints 25 lines of something, and the Python Shell (pythonw.exe) pops up!

There is no functionality in the Python Shell (=IDLE?) tho, and Ctrl+C'ing the window promts me to terminate the running program.

Posting the python.exe output:

>>> import idlelib.idle
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "C:\Python27\lib\idlelib\", line 11, in <module>
  File "C:\Python27\lib\idlelib\", line 1403, in main
    shell = flist.open_shell()
  File "C:\Python27\lib\idlelib\", line 281, in open_shell
    if not self.pyshell.begin():
  File "C:\Python27\lib\idlelib\", line 992, in begin
    client = self.interp.start_subprocess()
  File "C:\Python27\lib\idlelib\", line 417, in start_subprocess
  File "C:\Python27\lib\idlelib\", line 499, in transfer_path
    \n""" % (sys.path,))
  File "C:\Python27\lib\idlelib\", line 709, in runcommand
    self.rpcclt.remotequeue("exec", "runcode", (code,), {})
  File "C:\Python27\lib\idlelib\", line 216, in remotequeue
    return self.asyncreturn(seq)
  File "C:\Python27\lib\idlelib\", line 240, in asyncreturn
    response = self.getresponse(seq, wait=0.05)
  File "C:\Python27\lib\idlelib\", line 280, in getresponse
    response = self._getresponse(myseq, wait)
  File "C:\Python27\lib\idlelib\", line 300, in _getresponse
    response = self.pollresponse(myseq, wait)
  File "C:\Python27\lib\idlelib\", line 424, in pollresponse
    message = self.pollmessage(wait)
  File "C:\Python27\lib\idlelib\", line 376, in pollmessage
    packet = self.pollpacket(wait)
  File "C:\Python27\lib\idlelib\", line 347, in pollpacket
    r, w, x =[self.sock.fileno()], [], [], wait)
msg125466 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2011-01-05 20:27
Ah! You might want to take a look at #6941. Your firewall might be blocking IDLE's communications.

In Windows 7, if you go to Control Panel and search for "firewall" in the top right search box, it'll show an option to make an exception for a program.
msg125467 - (view) Author: Peter Heiberg (excubated) Date: 2011-01-05 20:47
My Windows Firewall have been turned off from the day I installed Win7, so that couldn't cause it..  I also tried deactivating UAC, with no luck.  Running with administrative privileges, without any results.
msg125732 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2011-01-08 00:02
Changed title based on 'command line works fine'.

You might try running test suite, 'python -m test.regrtest' from Command Window in python27 directory on both this and other system. (It takes about 20 min, so minimize and do something else.) test_tcl, text_tk, and test_ttk fail even when IDLE works, but maybe something else, not normally failing, will fail on this system (and not on one where IDLE works).
msg126521 - (view) Author: Peter Heiberg (excubated) Date: 2011-01-19 10:18
Run -> C:\Python27\python.exe -m test.regrtest
stops at "test_asynchat", been there for about 20mins.

Can't seem to break the operation tho (Ctrl+C), it still hangs at test_asynchat with the blinking underscore one line down.
msg171689 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2012-10-01 01:57
Peter, is this still an issue with 2.7.3?
msg172944 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2012-10-15 04:41
Running "python -m test.test_asynchat" succeeds on Windows 7 with version 2.7.3.

I'm closing this issue as it works for me. Feel free to re-open if you disagree.
Date User Action Args
2022-04-11 14:57:10adminsetgithub: 55043
2012-10-15 04:41:50roger.serwysetstatus: open -> closed
resolution: works for me
messages: + msg172944
2012-10-01 01:57:48roger.serwysetnosy: + roger.serwy
messages: + msg171689
2011-01-19 10:18:41excubatedsetfiles: + python test halt.jpg
nosy: loewis, terry.reedy, brian.curtin, excubated
messages: + msg126521
2011-01-08 13:38:10pitrousetnosy: + loewis
2011-01-08 00:02:51terry.reedysettitle: Python 2.7 x86 fails to run in Windows 7 -> Python 2.7 x86 IDLE fails to run in Windows 7
nosy: + terry.reedy

messages: + msg125732

components: + IDLE
2011-01-05 20:47:01excubatedsetnosy: brian.curtin, excubated
messages: + msg125467
2011-01-05 20:27:28brian.curtinsetnosy: brian.curtin, excubated
messages: + msg125466
2011-01-05 20:23:26excubatedsetnosy: brian.curtin, excubated
messages: + msg125465
2011-01-05 20:06:15excubatedsetnosy: brian.curtin, excubated
messages: + msg125464
2011-01-05 19:37:03brian.curtinsetnosy: brian.curtin, excubated
messages: + msg125460
2011-01-05 19:31:27excubatedsetnosy: brian.curtin, excubated
messages: + msg125459
2011-01-05 19:22:42brian.curtinsetnosy: brian.curtin, excubated
messages: + msg125457
2011-01-05 18:27:16excubatedsetnosy: brian.curtin, excubated
messages: + msg125450
2011-01-05 18:25:29excubatedsetnosy: brian.curtin, excubated
messages: + msg125448
2011-01-05 16:18:57brian.curtinsetnosy: + brian.curtin
messages: + msg125430

components: + Windows, - None
type: crash -> behavior
2011-01-05 10:41:02excubatedcreate