classification
Title: Build regression from automation changes on windows
Type: behavior Stage: resolved
Components: Build, Windows Versions: Python 3.2, Python 3.3
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: BreamoreBoy, ezio.melotti, gz, loewis, steve.dower, vstinner, zach.ware
Priority: normal Keywords: patch

Created on 2010-12-23 23:19 by gz, last changed 2016-09-16 03:25 by zach.ware. This issue is now closed.

Files
File name Uploaded Description Edit
py3k_build.patch gz, 2010-12-23 23:19 Throw quotes around till it works review
Messages (9)
msg124575 - (view) Author: Martin (gz) * Date: 2010-12-23 23:19
The build changes in r87093 broke me, as my py3k branch is under a dir with a space in the name, and the OutDir path needs escaping in the makefiles. Various extra quoting seems to be sufficient, though inelegant.
msg124577 - (view) Author: Martin (gz) * Date: 2010-12-23 23:38
Oh, and after building with this, I get:

$ svn st
?       PC/python3dll.obj

So either that wants moving or svn:ignore needs updating.
msg127261 - (view) Author: Martin (gz) * Date: 2011-01-28 09:25
My build is still affected by this, can you find some time to look at the attached patch please?

Relevant bit of log is:

Performing Makefile project actions
Microsoft (R) Program Maintenance Utility Version 9.00.21022.08
Copyright (C) Microsoft Corporation.  All rights reserved.
NMAKE : fatal error U1073: don't know how to make 'User\py3k\PCbuild\'
Stop.
Project : error PRJ0019: A tool returned an error code from "Performing Makefile project actions"
msg160161 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2012-05-07 17:02
Can you still reproduce this?
msg160215 - (view) Author: Martin (gz) * Date: 2012-05-08 17:26
Yes, this is still reproducible. For instance, by:

> hg clone -b default 3.3 "feature branch"
> cd "feature branch/PCbuild"
> call build_env.bat
> call build.bat

It seems python33.dll now does get created so it's less severe, but the python3dll still fails due to the makefile OutDir not being quoted:

NMAKE : fatal error U1073: don't know how to make 'branch\PCbuild\'
msg160237 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2012-05-09 00:33
As there is an easy work-around (just don't use spaces in directory names), I still consider this issue as irrelevant as two years ago.
msg160344 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2012-05-10 13:23
Avoiding spaces in the dir names might not be so easy, if e.g. you are trying to install it in "Program Files", "Users/Name Surname", or some other system directory that has spaces in there (sure, you could install it elsewhere, but in 2012 this shouldn't be an issue anymore).
msg220001 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-06-07 23:44
I agree with the sentiment expressed in msg160237.  Having said that I believe that a lot of work has been put into the build system recently that might have covered this.
msg276671 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2016-09-16 03:25
The build system has been completely rewritten at least once since this was opened; this should no longer be a problem.
History
Date User Action Args
2016-09-16 03:25:28zach.waresetstatus: open -> closed
resolution: out of date
messages: + msg276671

stage: patch review -> resolved
2014-06-29 09:46:01ezio.melottisetnosy: + vstinner, zach.ware, steve.dower
2014-06-08 00:17:52brian.curtinsetnosy: - brian.curtin
2014-06-07 23:44:20BreamoreBoysetnosy: + BreamoreBoy
messages: + msg220001
2012-05-10 13:23:01ezio.melottisetmessages: + msg160344
stage: patch review
2012-05-09 00:33:12loewissetmessages: + msg160237
2012-05-08 17:26:50gzsetmessages: + msg160215
versions: + Python 3.3
2012-05-07 21:09:22pitrousetnosy: + brian.curtin
2012-05-07 17:02:31ezio.melottisetnosy: + ezio.melotti
messages: + msg160161
2011-01-28 09:25:36gzsetmessages: + msg127261
2010-12-23 23:38:51gzsetmessages: + msg124577
2010-12-23 23:19:03gzcreate