classification
Title: Windows 2.4c1 installer default location issues
Type: Stage:
Components: Installation Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: loewis Nosy List: davemerrill, jbrouwers, loewis
Priority: normal Keywords:

Created on 2004-11-28 22:34 by davemerrill, last changed 2004-12-22 12:45 by loewis. This issue is now closed.

Messages (4)
msg23360 - (view) Author: dmerrill (davemerrill) Date: 2004-11-28 22:34
On win2k sp4, python-2.4c1.msi defaults to installing
in c:\Python24\, rather than the more usual c:\Program
Files\Python24\ like 2.3.3 did.

When I pointed it to c:\Program Files\Python24\, it
installed there, but I couldn't get IDLE to run; silent
failure. Not sure if there were other similar issues.
Uninstalled, and reinstalled to the default location,
all is (apparently, so far) well.
msg23361 - (view) Author: Jean M. Brouwers (jbrouwers) Date: 2004-12-01 16:30
Logged In: YES 
user_id=832557

More details on the IDLE issue in bug report 1076861, here

<https://sourceforge.net/tracker/index.php?func=detail&aid=1076861&group_id=5470&atid=105470>
msg23362 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2004-12-05 19:45
Logged In: YES 
user_id=21627

Not sure what the bug is that you are reporting here. It is
intentional that Python installs into c:\python24, not into
Program Files.

The IDLE problem indicates a bug, of course.
msg23363 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2004-12-22 12:45
Logged In: YES 
user_id=21627

The IDLE problem is fixed for 2.4.1, by properly supporting 
spaces in the target directory name. The default location is 
not a bug.
History
Date User Action Args
2004-11-28 22:34:50davemerrillcreate