classification
Title: fwbackups python lib error
Type: Stage: resolved
Components: Library (Lib) Versions: Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: elmasry-ayman, eric.smith, r.david.murray
Priority: normal Keywords:

Created on 2010-12-18 08:49 by elmasry-ayman, last changed 2010-12-18 16:43 by r.david.murray. This issue is now closed.

Messages (4)
msg124276 - (view) Author: Ayman Elmasry (elmasry-ayman) Date: 2010-12-18 08:49
I hope this topic is not completely unfitting here.

fwbackups error after backup attempt which concerned python lib:

ERROR : Traceback (most recent call last):   File "/usr/lib/python2.4/site-packages/fwbackups/operations/backup.py", line 698, in start  pkgListfiles = self.createPkgLists()   File "/usr/lib/python2.4/site-packages/fwbackups/operations/backup.py", line 85, in createPkgLists   fh = tempfile.NamedTemporaryFile(suffix='.txt', prefix="%s - tmp" % _('rpm - Package list'), delete=False)  TypeError: NamedTemporaryFile() got an unexpected keyword argument 'delete'
msg124283 - (view) Author: Eric V. Smith (eric.smith) * (Python committer) Date: 2010-12-18 13:25
fwbackups is a third party package. See if you can submit a bug at http://www.diffingo.com/oss/fwbackups
msg124284 - (view) Author: Ayman Elmasry (elmasry-ayman) Date: 2010-12-18 14:38
thank you
msg124290 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-12-18 16:43
Ayman: FYI it looks like you are trying to run the program on a Python version older than what it requires (the delete keyword for NamedTemporaryFile was introduced in version 2.6, as you can find out by looking it up in the python documentation for the tempfile module).
History
Date User Action Args
2010-12-18 16:43:57r.david.murraysetnosy: + r.david.murray
messages: + msg124290
2010-12-18 14:38:55elmasry-aymansetnosy: eric.smith, elmasry-ayman
messages: + msg124284
2010-12-18 13:25:40eric.smithsetstatus: open -> closed

nosy: + eric.smith
messages: + msg124283

resolution: not a bug
stage: resolved
2010-12-18 08:49:30elmasry-aymancreate