classification
Title: test_threadsignals hang on FreeBSD 6.4
Type: behavior Stage:
Components: Library (Lib), Tests Versions: Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder: interruption of locks by signals not guaranteed when locks are implemented using POSIX condition variables; add sys.thread_info
View: 11223
Assigned To: Nosy List: db3l, pitrou, rnk, vstinner
Priority: normal Keywords:

Created on 2010-12-16 18:02 by pitrou, last changed 2011-02-16 15:40 by pitrou. This issue is now closed.

Messages (5)
msg124141 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2010-12-16 18:02
The title says it all. This is related to r87292 (issue8844).
msg125493 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-01-06 00:59
test_threadsignals hang on "x86 FreeBSD 3.x" buildbot since at least the 17th december (build 1030, r87341).

What is "FreeBSD 6.4"? Another buildbot?
msg125494 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-01-06 01:03
test_threadsignals hang also on "x86 gentoo 3.x" since at least the 17th december (build 3681, r87348).
msg125495 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-01-06 01:10
"x86 gentoo 3.x" is an old Linux setup, see #4970: glibc 2.3.4, linuxthreads-0.10 and Linux kernel 2.6.9-gentoo-r1. linuxthreads is the old implementation of threads on Linux. It was replaced by NPTL with Linux kernel 2.6 and the GNU libc 2.4.

#4970 was fixed by r80108: skip the test if linuxthreads is used.
msg125497 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-01-06 01:13
I am unable to reproduce test_threadsignals hang with my FreeBSD 8.0 VM. A bug was maybe fixed between FreeBSD 7.2 and FreeBSD 8.0?
History
Date User Action Args
2011-02-16 15:40:47pitrousetstatus: open -> closed
resolution: duplicate
superseder: interruption of locks by signals not guaranteed when locks are implemented using POSIX condition variables; add sys.thread_info
nosy: db3l, pitrou, vstinner, rnk
2011-01-06 01:13:06vstinnersetnosy: db3l, pitrou, vstinner, rnk
messages: + msg125497
2011-01-06 01:10:06vstinnersetnosy: db3l, pitrou, vstinner, rnk
messages: + msg125495
2011-01-06 01:03:19vstinnersetnosy: db3l, pitrou, vstinner, rnk
messages: + msg125494
2011-01-06 00:59:51vstinnersetnosy: + vstinner
messages: + msg125493
2010-12-16 18:02:04pitroucreate