classification
Title: Regex 0.1.20101210 Python 3.1 install problem Mac OS X 10.6.5
Type: Stage:
Components: Installation Versions: Python 3.1
process
Status: closed Resolution: not a bug
Dependencies: Superseder: Adding a new regex module (compatible with re)
View: 2636
Assigned To: Nosy List: belopolsky, mrabarnett, ned.deily, stiv
Priority: normal Keywords:

Created on 2010-12-14 18:08 by stiv, last changed 2010-12-14 22:42 by belopolsky. This issue is now closed.

Files
File name Uploaded Description Edit
regex-0.1.20101210-python31-install-error stiv, 2010-12-14 18:08 regex-0.1.20101210 install error log for Python 3.1 on Mac OS X 10.6.5 with Xcode 3.2.2
Messages (9)
msg123964 - (view) Author: Steve Moran (stiv) Date: 2010-12-14 18:08
Package doesn't want to install on Mac OS X 10.6.5 with Python 3.1 using instructions "python3.1 setup.py install" (or "sudo python3.1 setup.py install").

Compiling with an SDK that doesn't seem to exist: /Developer/SDKs/MacOSX10.4u.sdk

Extended error log attached.

NB: I realize this package is in dev and it's got less than 50 current downloads. Thought I'd post anyway. I appreciate any input. Xcode is installed v 3.2.2. 64-bit.
msg123966 - (view) Author: Alexander Belopolsky (belopolsky) * (Python committer) Date: 2010-12-14 18:12
Regex 0.1.20101210 is not part of the standard Python distribution, so this bug report is invalid.  See issue2636 for the development status of regex.
msg123967 - (view) Author: Steve Moran (stiv) Date: 2010-12-14 18:27
Yeah, it's not immediately clear how to bring this up at

http://bugs.python.org/issue2636

On Tue, 14 Dec 2010, Alexander Belopolsky wrote:

>
> Alexander Belopolsky <belopolsky@users.sourceforge.net> added the comment:
>
> Regex 0.1.20101210 is not part of the standard Python distribution, so this bug report is invalid.  See issue2636 for the development status of regex.
>
> ----------
> nosy: +belopolsky
> resolution:  -> invalid
> status: open -> closed
> superseder:  -> Regexp 2.7 (modifications to current re 2.2.2)
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue10704>
> _______________________________________
>
msg123970 - (view) Author: Alexander Belopolsky (belopolsky) * (Python committer) Date: 2010-12-14 18:49
On Tue, Dec 14, 2010 at 1:27 PM, Steve Moran <report@bugs.python.org> wrote:
..
> Yeah, it's not immediately clear how to bring this up at
>
> http://bugs.python.org/issue2636
>

This is the URL listed as the home page for regex 0.1.20101210 on PyPI
[1], so I assume the author(s) will be listening.  You can also
contact the author directly:

Matthew Barnett <regex at mrabarnett plus com>

[1] http://pypi.python.org/pypi/regex/0.1.20101210
msg123975 - (view) Author: Matthew Barnett (mrabarnett) * (Python triager) Date: 2010-12-14 19:37
I use Windows XP, so I can't help with MacOS X.

From the error log it looks like it doesn't like the sources for Python either!
msg123981 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2010-12-14 22:17
The 10.4u SDK is an optional install in the OS X 10.6 Xcode Developer Tools package.  There is an option in the Xcode installer to customize; just select the 10.4u package to install it.
msg123983 - (view) Author: Alexander Belopolsky (belopolsky) * (Python committer) Date: 2010-12-14 22:26
FWIW, I was able to install Regex 0.1.20101210 on OSX 10.6.4, 

Developer Information:

  Version:	3.2 (10M2003)
  Location:	/Developer
  Applications:
  Xcode:	3.2.1 (1613)
  Interface Builder:	3.2.1 (740)
  Instruments:	2.0.1 (1096)
  Dashcode:	3.0 (328)
  SDKs:
  Mac OS X:
  10.5:	(9J61)
  10.6:	(10M2003)

using either python 3.1.2 or current py3k branch from svn.
msg123985 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2010-12-14 22:36
When you use python 3.1 from a python.org OS X installer, it is built with the 10.4u SDK and a deployment target of 10.3 and up. Distutils ensures that any extension modules are built using the same values as the interpreter itself which is why the 10.4u SDK is needed.  This is true for all current 32-bit ("10.3+") python.org installers for OS X.  If you build it yourself, you have other options.
msg123988 - (view) Author: Alexander Belopolsky (belopolsky) * (Python committer) Date: 2010-12-14 22:42
> If you build it yourself, you have other options.

Yes, my python3.1 is from MacPorts.
History
Date User Action Args
2010-12-14 22:42:02belopolskysetmessages: + msg123988
2010-12-14 22:36:57ned.deilysetmessages: + msg123985
2010-12-14 22:26:20belopolskysetmessages: + msg123983
2010-12-14 22:17:56ned.deilysetnosy: + ned.deily
messages: + msg123981
2010-12-14 19:37:35mrabarnettsetmessages: + msg123975
2010-12-14 18:49:59belopolskysetmessages: + msg123970
2010-12-14 18:34:52r.david.murraysetnosy: + mrabarnett
2010-12-14 18:27:56stivsetmessages: + msg123967
2010-12-14 18:12:11belopolskysetstatus: open -> closed

nosy: + belopolsky
messages: + msg123966

superseder: Adding a new regex module (compatible with re)
resolution: not a bug
2010-12-14 18:08:54stivcreate