classification
Title: endianness detection fails on IRIX 5.3
Type: Stage: resolved
Components: Installation Versions: Python 2.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: gschwarz, loewis
Priority: normal Keywords:

Created on 2004-11-20 19:01 by gschwarz, last changed 2009-04-25 21:38 by ajaksu2. This issue is now closed.

Messages (2)
msg60602 - (view) Author: Georg Schwarz (gschwarz) Date: 2004-11-20 19:01
Configuring python 2.3.4 on IRIX 5.3 fails as follows:

checking whether byte ordering is bigendian... unknown
configure: error: unknown endianness
presetting ac_cv_c_bigendian=no (or yes) will help
*** Error code 1

The problem is that the respective defines are in sys/
endian.h, which is not being included in the test code.
msg60603 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2005-01-29 14:22
Logged In: YES 
user_id=21627

Unfortunately, there is not much we can do about this (with
acceptable efforts); we use the AC_C_BIGENDIAN macro of
autoconf which probably needs to be changed.

It would be best if you could report this problem to autoconf.
History
Date User Action Args
2009-04-25 21:38:39ajaksu2setstatus: pending -> closed
resolution: not a bug
stage: resolved
2009-02-16 17:52:07ajaksu2setstatus: open -> pending
2004-11-20 19:01:34gschwarzcreate