classification
Title: make testall no longer working on Darwin
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Add -h/--help option to compileall
View: 10453
Assigned To: Nosy List: donmez, r.david.murray
Priority: normal Keywords:

Created on 2010-12-13 08:26 by donmez, last changed 2010-12-13 14:31 by r.david.murray. This issue is now closed.

Messages (2)
msg123865 - (view) Author: Ismail Donmez (donmez) * Date: 2010-12-13 08:26
Using py3k r87206 on Mac OSX 10.6.5,

[~/Sources/py3k]> make testall
running build
running build_ext
building dbm using ndbm

Python build finished, but the necessary bits to build these modules were not found:
_gdbm              ossaudiodev        spwd            
To find the necessary bits, look in setup.py in detect_modules() for the module's name.

running build_scripts
find ./Lib -name '*.py[co]' -print | xargs rm -f
./python -Wd -E -bb  ./Lib/compileall.py
Traceback (most recent call last):
  File "./Lib/compileall.py", line 223, in <module>
    exit_status = int(not main())
  File "./Lib/compileall.py", line 205, in main
    if os.path.isdir(dest):
  File "/Users/cartman/Sources/py3k/Lib/genericpath.py", line 41, in isdir
    st = os.stat(s)
TypeError: Can't convert 'NoneType' object to str implicitly
make: *** [testall] Error 1
msg123876 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-12-13 14:31
I'm not sure why you would be seeing a test failure on OSX when we aren't seeing it on other platforms, but the cause of the bug is known.  It should be fixed by the last patch attached to issue 10453.  If you could test that patch it would be great, but please comment on that issue; I'm going to close this one as a duplicate.
History
Date User Action Args
2010-12-13 14:31:51r.david.murraysetstatus: open -> closed

superseder: Add -h/--help option to compileall

nosy: + r.david.murray
messages: + msg123876
resolution: duplicate
stage: resolved
2010-12-13 08:26:01donmezcreate