classification
Title: pydoc removes lib directory
Type: behavior Stage: resolved
Components: Versions: Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: "python -m pydoc -g" fails
View: 2029
Assigned To: Nosy List: CZ, r.david.murray
Priority: normal Keywords:

Created on 2010-12-12 22:38 by CZ, last changed 2010-12-12 22:41 by r.david.murray. This issue is now closed.

Messages (2)
msg123853 - (view) Author: CZ (CZ) Date: 2010-12-12 22:38
when pydoc is run with "python -m" (e.g., "python -m pydoc map"),
you will receive an error message: No module named tempfile.

The reason is pydoc removes 'C:\Python26\lib' (in my case) from sys.path.

But you can run it as "python <full path to pydoc.py>" because the lib directory appears twice in the sys.path in such situation.
msg123854 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-12-12 22:41
This is a duplicate of issue 2029.
History
Date User Action Args
2010-12-12 22:41:31r.david.murraysetstatus: open -> closed

superseder: "python -m pydoc -g" fails

nosy: + r.david.murray
messages: + msg123854
resolution: duplicate
stage: resolved
2010-12-12 22:38:43CZcreate