classification
Title: ["with"] new in version 2.6 instead of 2.5
Type: Stage:
Components: Documentation Versions: Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, georg.brandl, karmaguedon
Priority: normal Keywords:

Created on 2010-12-10 12:48 by karmaguedon, last changed 2010-12-10 13:24 by georg.brandl. This issue is now closed.

Messages (2)
msg123731 - (view) Author: Mayweed (karmaguedon) Date: 2010-12-10 12:48
In the documentation, the statement "with" is marked as:
"New in version 2.5."
(http://docs.python.org/reference/compound_stmts.html#the-with-statement)

This new statement is new in version 2.6 !
msg123732 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2010-12-10 13:24
It is in fact new in 2.5, but only available when using "from __future__ import with_statement", which the note near the end of the section details.
History
Date User Action Args
2010-12-10 13:24:42georg.brandlsetstatus: open -> closed

nosy: + georg.brandl
messages: + msg123732

resolution: not a bug
2010-12-10 12:48:25karmaguedoncreate