classification
Title: chr(13) is added before chr(10) when issuing ".write" under windows
Type: Stage:
Components: IO, Windows Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: KZM, amaury.forgeotdarc
Priority: normal Keywords:

Created on 2010-12-08 14:39 by KZM, last changed 2010-12-08 14:49 by amaury.forgeotdarc. This issue is now closed.

Files
File name Uploaded Description Edit
chr13remove.py KZM, 2010-12-08 14:39
Messages (2)
msg123608 - (view) Author: Vladimir K (KZM) Date: 2010-12-08 14:39
The following code (see attached file) was intended to remove chr(13) from end-of-lines under Windows to make the file Unix-compliant but it always appends chr(13) before chr(10).

I'm under Windows XP.
msg123610 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2010-12-08 14:49
On Windows, newlines in text files are always translated. Please read
http://docs.python.org/tutorial/inputoutput.html#reading-and-writing-files
History
Date User Action Args
2010-12-08 14:49:03amaury.forgeotdarcsetstatus: open -> closed

nosy: + amaury.forgeotdarc
messages: + msg123610

resolution: not a bug
2010-12-08 14:39:35KZMcreate