classification
Title: SystemError on pickling bytes >= 4GB
Type: Stage:
Components: Library (Lib) Versions: Python 3.1
process
Status: closed Resolution: duplicate
Dependencies: Superseder: pickle not 64-bit ready
View: 11564
Assigned To: Nosy List: alexandre.vassalotti, amaury.forgeotdarc, hagen, janglin, pitrou, r.david.murray, santoso.wijaya
Priority: normal Keywords:

Created on 2010-12-06 19:33 by hagen, last changed 2012-12-15 19:15 by pitrou. This issue is now closed.

Messages (3)
msg123499 - (view) Author: Hagen Fürstenau (hagen) Date: 2010-12-06 19:33
Pickling a bytes object of length >= 2**32 results in a "SystemError: error return without exception set".

If pickling large bytes objects isn't supported, this should be documented and a helpful exception be raised.
msg123502 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-12-06 19:52
I suspect this is a duplicate of issue 9614, or rather a subset of that issue.
msg177550 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2012-12-15 19:15
It should actually have been fixed in issue 11564. Please reopen if you can reproduce with a recent 3.x Python.
History
Date User Action Args
2012-12-15 19:15:18pitrousetstatus: pending -> closed
superseder: pickle not 64-bit ready
resolution: duplicate
messages: + msg177550
2012-12-02 10:27:47serhiy.storchakasetstatus: open -> pending
2011-04-26 17:51:32santoso.wijayasetnosy: + santoso.wijaya
2010-12-06 19:52:56r.david.murraysetnosy: + pitrou, amaury.forgeotdarc, alexandre.vassalotti, janglin, r.david.murray
messages: + msg123502
2010-12-06 19:33:06hagencreate