classification
Title: WebKit browsers show superfluous scrollbars in html docs
Type: behavior Stage: resolved
Components: Documentation Versions: Python 3.1, Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: davide.rizzo, docs@python, gregory.p.smith, r.david.murray
Priority: normal Keywords: patch

Created on 2010-12-04 11:32 by davide.rizzo, last changed 2010-12-18 19:43 by r.david.murray. This issue is now closed.

Files
File name Uploaded Description Edit
webkit.patch davide.rizzo, 2010-12-04 11:32
Messages (3)
msg123338 - (view) Author: Davide Rizzo (davide.rizzo) * Date: 2010-12-04 11:32
Some WebKit browsers show a superflous scrollbar on the right side of the <pre> boxes in the Sphinx generated html docs.

For example:
http://666kb.com/i/boxys2zktxky17vsh.png
taken on Chrome 7 on Windows.

I believe that the cause of the behaviour is a bug in the WebKit engine. If that's the case, adding "overflow-y: hidden" to the <pre> css style would fix the issue.
"overflow-y" is not standard css, but it is understood by the affected browsers, looks ok on other modern browsers and is just ignored on older releases.

The provided patch has been tested on all major Windows browsers.
msg123339 - (view) Author: Gregory P. Smith (gregory.p.smith) * (Python committer) Date: 2010-12-04 11:39
r87027 has it for py3k / 3.2.  needs backporting to the other branches.
msg124312 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-12-18 19:43
Backport done in r87387 and r87388.
History
Date User Action Args
2010-12-18 19:43:47r.david.murraysetstatus: open -> closed

nosy: + r.david.murray
messages: + msg124312

resolution: fixed
stage: resolved
2010-12-04 11:39:26gregory.p.smithsetnosy: + gregory.p.smith

messages: + msg123339
versions: - Python 3.2
2010-12-04 11:32:33davide.rizzocreate