classification
Title: ElementTree documentation
Type: enhancement Stage:
Components: XML Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: effbot Nosy List: adrian_nye, akuchling, effbot, sandro.tosi
Priority: normal Keywords:

Created on 2010-12-02 14:51 by adrian_nye, last changed 2016-11-06 21:21 by akuchling. This issue is now closed.

Messages (3)
msg123076 - (view) Author: Adrian Nye (adrian_nye) Date: 2010-12-02 14:51
TreeBuilder doc does not mention its "entity" argument which is the main way to deal with html entity encodings which are unfortunately a common problem in XML.

Also the doc needs a discussion of the relationship of TreeBuilder and XMLParser.   The former has "entity", and the latter has "encoding", but
what happens is you need both?   Needs examples of using these two classes.
msg133748 - (view) Author: Sandro Tosi (sandro.tosi) * (Python committer) Date: 2011-04-14 16:54
Hi Adrian,
where do you see the 'entity' argument to class TreeBuilder?

In case I'm just missing in, would be interested in preparing a patch? you seem to be knowledgeable about the matter, so it would be nice if you can share it with us. You can also provide just the text you'd like to see, and I'll do the rest.
msg280175 - (view) Author: A.M. Kuchling (akuchling) * (Python committer) Date: 2016-11-06 21:21
I don't see an 'entity' argument or attribute for TreeBuilder either.  XMLParser has a .entity attribute, though.  Perhaps this was simple confusion?  Adrian: please feel free to re-open and provide a patch if there's actually a bug here.
History
Date User Action Args
2016-11-06 21:21:12akuchlingsetstatus: open -> closed

nosy: + akuchling
messages: + msg280175

resolution: not a bug
2011-04-14 16:54:50sandro.tosisetnosy: + sandro.tosi
messages: + msg133748
2010-12-16 09:11:22rhettingersetassignee: effbot

nosy: + effbot
2010-12-02 14:51:15adrian_nyecreate