classification
Title: Encoding issue with chm help in 2.7.1
Type: behavior Stage:
Components: Documentation, Windows Versions: Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: BreamoreBoy, Kristian.Vlaardingerbroek, docs@python, flashk, georg.brandl, loewis, sandro.tosi, zach.ware
Priority: normal Keywords:

Created on 2010-11-29 19:48 by flashk, last changed 2014-10-06 16:30 by georg.brandl. This issue is now closed.

Messages (11)
msg122857 - (view) Author: (flashk) Date: 2010-11-29 19:48
I just updated to Python 2.7.1 and noticed a small issue with the chm help file.

The search results tab displays incorrect characters for various topic titles. It seems to be an encoding issue.

For example, searching for 'json' yields the following results:

 - 18.2 json — JSON encoder and decoder
 - What’s New in Python 2.6

I noticed this issue on Windows XP 32-bit and Windows 7 64-bit.

This issue does not exist with the 2.7 chm file.
msg139045 - (view) Author: Sandro Tosi (sandro.tosi) * (Python committer) Date: 2011-06-25 11:22
Hello, can you still replicate it with 2.7.2 ?
msg139053 - (view) Author: Kristian Vlaardingerbroek (Kristian.Vlaardingerbroek) Date: 2011-06-25 13:01
I can reproduce the issue with Python 2.7.2 and Python 3.2 on Windows 7 Enterprise SP 1 64-bit.
msg139058 - (view) Author: Sandro Tosi (sandro.tosi) * (Python committer) Date: 2011-06-25 13:08
Adding Georg to nosy, he might now how CHM is generated on Windows and shine some light here
msg139060 - (view) Author: Kristian Vlaardingerbroek (Kristian.Vlaardingerbroek) Date: 2011-06-25 13:24
I've looked at the output from make html and make htmlhelp and taking the library/json.html as example the text between <title> </title> is exactly the same.

Chrome renders both fine:

<title>18.2. json — JSON encoder and decoder &mdash; Python v2.7.2 documentation</title>

But when looking at the file in the HTML Help Workshop it looks like this:

 <title>18.2. json — JSON encoder and decoder</title>

Which is what you see when doing the search.
msg139063 - (view) Author: Kristian Vlaardingerbroek (Kristian.Vlaardingerbroek) Date: 2011-06-25 13:38
This might be non-fixable:

http://support.microsoft.com/kb/269766/

HTML Help 1.x does not compile the Unicode characters. Meaning that in the search and index views you'll get garbage. For the rest of the rendering IE is used which does render the correct characters.

There is support in HTML Help 2.x but as far as I can see that is only available as a component in Visual Studio and not included with a default Windows installation.
msg139193 - (view) Author: (flashk) Date: 2011-06-26 18:01
Yes, I still notice this issue with the 2.7.2 release.

As I mentioned earlier, I did not notice this problem with 2.7. Were there any significant changes to the docs between 2.7 and 2.7.1?

Considering the bug with HTML Help pointed out by Kristian, I'm thinking there was either a change in the html encoding or the build environment for the Windows installer. Anybody aware of either of these changes happening between 2.7 and 2.7.1?
msg222500 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-07-07 19:26
I don't see this in 3.4.1.
msg222511 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2014-07-07 20:19
I do in 2.7.8, though.  This appears to have been a Sphinx issue (likely caused by HTML Help's lack of Unicode support), introduced sometime between Sphinx versions 0.6.5 and 0.6.7, and fixed sometime between versions 1.1.3 and 1.2.2.
msg225471 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-08-17 21:05
Is there anything to be done here as Sphinx is a third party tool and the root cause is already fixed?
msg228721 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2014-10-06 16:30
Agreed, closing.
History
Date User Action Args
2014-10-06 16:30:52georg.brandlsetstatus: open -> closed
resolution: fixed
messages: + msg228721
2014-08-17 21:05:26BreamoreBoysetmessages: + msg225471
2014-07-07 20:19:21zach.waresetnosy: + zach.ware
messages: + msg222511
2014-07-07 19:26:33BreamoreBoysetnosy: + BreamoreBoy
messages: + msg222500
2011-06-26 18:01:04flashksetmessages: + msg139193
2011-06-25 13:38:14Kristian.Vlaardingerbroeksetmessages: + msg139063
2011-06-25 13:24:39Kristian.Vlaardingerbroeksetmessages: + msg139060
2011-06-25 13:08:12sandro.tosisetnosy: + georg.brandl
messages: + msg139058
2011-06-25 13:01:07Kristian.Vlaardingerbroeksetnosy: + Kristian.Vlaardingerbroek
messages: + msg139053
2011-06-25 11:22:00sandro.tosisetnosy: + sandro.tosi
messages: + msg139045
2010-11-29 20:15:16loewissetnosy: + loewis
2010-11-29 19:48:26flashkcreate