classification
Title: AttributeError: 'NoneType' object has no attribute 'name' (bonenode.name)
Type: behavior Stage: resolved
Components: Windows Versions: Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Drakonnen, eric.araujo
Priority: normal Keywords:

Created on 2010-11-21 02:45 by Drakonnen, last changed 2010-11-21 02:49 by eric.araujo. This issue is now closed.

Messages (2)
msg121840 - (view) Author: (Drakonnen) Date: 2010-11-21 02:45
Trying to import a .nif into Blender, for Oblivion mod work, I get the following error:

Blender NIF Scripts 2.5.5 (running on Blender 249, PyFFI 2.1.6)
pyffi.toaster:INFO:--- fix_mergeskeletonroots ---
pyffi.toaster:INFO:  ~~~ NiNode [Scene Root] ~~~
pyffi.toaster:INFO:--- fix_sendgeometriestobindposition ---
pyffi.toaster:INFO:  ~~~ NiNode [Scene Root] ~~~
pyffi.toaster:INFO:    sending geometries to bind position
Traceback (most recent call last):
  File "C:\Program Files (x86)\Blender Foundation\Blender\.blender\scripts\bpymo
dules\nif_common.py", line 1227, in gui_button_event
    self.gui_exit()
  File "C:\Program Files (x86)\Blender Foundation\Blender\.blender\scripts\bpymo
dules\nif_common.py", line 1579, in gui_exit
    self.callback(**self.config)
  File "C:\Program Files (x86)\Blender Foundation\Blender\.blender\scripts\impor
t\import_nif.py", line 3750, in config_callback
    importer = NifImport(**config)
  File "C:\Program Files (x86)\Blender Foundation\Blender\.blender\scripts\impor
t\import_nif.py", line 274, in __init__
    self.import_root(root)
  File "C:\Program Files (x86)\Blender Foundation\Blender\.blender\scripts\impor
t\import_nif.py", line 309, in import_root
    pyffi.spells.nif.fix.SpellSendGeometriesToBindPosition(data=data).recurse()
  File "C:\Python26\lib\site-packages\pyffi\spells\__init__.py", line 289, in re
curse
    self.recurse(child)
  File "C:\Python26\lib\site-packages\pyffi\spells\__init__.py", line 298, in re
curse
    if self.branchentry(branch):
  File "C:\Python26\lib\site-packages\pyffi\spells\nif\__init__.py", line 135, i
n branchentry
    self.skelrootentry(branch)
  File "C:\Python26\lib\site-packages\pyffi\spells\nif\fix.py", line 380, in ske
lrootentry
    branch.send_geometries_to_bind_position()
  File "C:\Python26\lib\site-packages\pyffi\formats\nif\__init__.py", line 5106,
 in send_geometries_to_bind_position
    if bonenode.name in bone_bind_transform:
AttributeError: 'NoneType' object has no attribute 'name'
msg121842 - (view) Author: √Čric Araujo (eric.araujo) * (Python committer) Date: 2010-11-21 02:49
This is not a bug in Python but in the third-party pyffi project.  Please report it to them.
History
Date User Action Args
2010-11-21 02:49:20eric.araujosetstatus: open -> closed

nosy: + eric.araujo
messages: + msg121842

resolution: not a bug
stage: resolved
2010-11-21 02:45:55Drakonnencreate