classification
Title: test_glob fails with UnicodeDecodeError
Type: behavior Stage:
Components: Windows Versions: Python 3.0
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: christian.heimes, theller
Priority: high Keywords: rfe

Created on 2007-08-28 06:11 by theller, last changed 2007-11-08 13:45 by christian.heimes. This issue is now closed.

Messages (3)
msg55354 - (view) Author: Thomas Heller (theller) * (Python committer) Date: 2007-08-28 06:11
Unicode errors in various tests - not only in test_glob:

  test_glob
  test test_glob failed -- Traceback (most recent call last):
    File "c:\svn\py3k\lib\test\test_glob.py", line 87, in
test_glob_directory_names
      eq(self.glob('*', '*a'), [])
    File "c:\svn\py3k\lib\test\test_glob.py", line 41, in glob
      res = glob.glob(p)
    File "c:\svn\py3k\lib\glob.py", line 16, in glob
      return list(iglob(pathname))
    File "c:\svn\py3k\lib\glob.py", line 42, in iglob
      for name in glob_in_dir(dirname, basename):
    File "c:\svn\py3k\lib\glob.py", line 56, in glob1
      names = os.listdir(dirname)
  UnicodeDecodeError: 'utf8' codec can't decode bytes in position 27-31:
unexpected end of data
msg56842 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2007-10-27 03:41
I think the problem is solved now. I haven't seen glob crashing for a while.
msg57240 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2007-11-08 13:45
I'm unable to reproduce the error and I haven't seen it for a long time.
Closing
History
Date User Action Args
2007-11-08 13:45:55christian.heimessetstatus: open -> closed
keywords: + rfe
resolution: out of date
messages: + msg57240
type: behavior
2007-10-27 03:41:23christian.heimessetnosy: + christian.heimes
messages: + msg56842
2007-09-17 06:30:08jafosetpriority: high
2007-08-28 06:11:28thellercreate