classification
Title: sporadic test_bsddb3 failures
Type: behavior Stage: resolved
Components: Library (Lib), Tests Versions: Python 2.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: jcea Nosy List: BreamoreBoy, jcea, ocean-city, pitrou
Priority: normal Keywords: buildbot

Created on 2010-11-13 00:51 by pitrou, last changed 2014-06-28 14:03 by jcea. This issue is now closed.

Messages (4)
msg121100 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2010-11-13 00:51
test_bsddb3 often produces the following failure under the Windows buildbots. It could probably be solved by choosing a larger timeout (time.time() on Windows is rather imprecise):

test test_bsddb3 failed -- Traceback (most recent call last):
  File "D:\cygwin\home\db3l\buildarea\2.7.bolen-windows7\build\lib\bsddb\test\test_lock.py", line 139, in test04_lock_timeout2
    self.assertTrue((end_time-start_time) >= 0.0999)
AssertionError: False is not True
msg122331 - (view) Author: Hirokazu Yamamoto (ocean-city) * (Python committer) Date: 2010-11-25 05:10
This should be duplicate of #3892.

I suppose timeout in this test might be very short. Refers to
http://www.systomath.eu/doc/BerkeleyDb-4.7/html/api_c/rep_timeout.html
timeout is in microseconds, so
  self.dbenvMaster.rep_set_timeout(db.DB_REP_CONNECTION_RETRY,100123)
means only 100 milliseconds. (I don't know BSDDB entirely, so maybe this
might be valid value though)
msg221709 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-06-27 18:57
As #3892 has been closed this can also be closed.
msg221788 - (view) Author: Jesús Cea Avión (jcea) * (Python committer) Date: 2014-06-28 14:03
Closed as requested.
History
Date User Action Args
2014-06-28 14:03:10jceasetstatus: open -> closed
resolution: out of date
messages: + msg221788

stage: needs patch -> resolved
2014-06-27 18:57:47BreamoreBoysetnosy: + BreamoreBoy
messages: + msg221709
2010-11-25 05:10:39ocean-citysetnosy: + ocean-city
messages: + msg122331
2010-11-13 00:51:35pitroucreate