classification
Title: Typo in results of help(divmod)
Type: behavior Stage:
Components: Documentation Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Trundle, docs@python, rdfuhr
Priority: normal Keywords:

Created on 2010-11-09 21:00 by rdfuhr, last changed 2010-11-10 06:35 by rdfuhr. This issue is now closed.

Messages (4)
msg120900 - (view) Author: Richard Fuhr (rdfuhr) Date: 2010-11-09 21:00
When running Python 2.7 if you invoke 

help(divmod)

the first line of the resulting help displays

Help on built-in function divmod in module __builtin__:

but I believe that the name of the module is __builtins__

so the line should say

Help on built-in function divmod in module __builtinsq__:
msg120901 - (view) Author: Richard Fuhr (rdfuhr) Date: 2010-11-09 21:04
I had a typo in my own bug report that was reporting a typo; what I intended to say was the following ( the q should not have been there at the end )

When running Python 2.7 if you invoke 

help(divmod)

the first line of the resulting help displays

Help on built-in function divmod in module __builtin__:

but I believe that the name of the module is __builtins__

so the line should say

Help on built-in function divmod in module __builtins__:
msg120906 - (view) Author: Andreas Stührk (Trundle) * Date: 2010-11-09 23:54
__builtin__ is the correct name for the module (see http://docs.python.org/library/__builtin__.html, especially the note at the end which is the cause of the confusion), hence this is not a bug.
msg120914 - (view) Author: Richard Fuhr (rdfuhr) Date: 2010-11-10 06:35
OK, thanks for the clarification. I am new to Python. 

Sent from my iPod

On Nov 9, 2010, at 3:54 PM, Andreas Stührk <report@bugs.python.org> wrote:

> 
> Andreas Stührk <andy-python@hammerhartes.de> added the comment:
> 
> __builtin__ is the correct name for the module (see http://docs.python.org/library/__builtin__.html, especially the note at the end which is the cause of the confusion), hence this is not a bug.
> 
> ----------
> nosy: +Trundle
> 
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue10378>
> _______________________________________
History
Date User Action Args
2010-11-10 06:35:15rdfuhrsetmessages: + msg120914
2010-11-09 23:55:58benjamin.petersonsetstatus: open -> closed
resolution: not a bug
2010-11-09 23:54:01Trundlesetnosy: + Trundle
messages: + msg120906
2010-11-09 21:04:39rdfuhrsetmessages: + msg120901
2010-11-09 21:00:50rdfuhrcreate