classification
Title: Setup Script example incorrect
Type: behavior Stage: resolved
Components: Documentation Versions: Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: eric.araujo Nosy List: docs@python, eric.araujo, fdrake, lensart
Priority: normal Keywords:

Created on 2010-11-09 13:09 by lensart, last changed 2010-11-12 22:04 by eric.araujo. This issue is now closed.

Messages (4)
msg120863 - (view) Author: Kirk Clendinning (lensart) Date: 2010-11-09 13:09
In 2.7. Installing Additional Files the example shows:

setup(...,
      data_files=[('bitmaps', ['bm/b1.gif', 'bm/b2.gif']),
                  ('config', ['cfg/data.cfg']),
                  ('/etc/init.d', ['init-script'])]
     )

However, running easy_install with setuptools results in a error:

Setup script exited with error: SandboxViolation: open('/etc/init.d/init-script', 'wb') {}

Perhaps the documentation should be changed and more explanation added.
msg121048 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-11-12 17:21
Thanks for the report.  Setuptools is not a part of Python, and distutils docs don’t mention issues specific to third-party tools.  I think I will reject this bug.
msg121083 - (view) Author: Kirk Clendinning (lensart) Date: 2010-11-12 21:53
Interesting... the link at the bottom of the page for reporting bugs went to the python bug tracker.. perhaps the web page should be checked for an incorrect link.

-k-

On Nov 12, 2010, at 18:22 , Éric Araujo wrote:

> 
> Éric Araujo <merwok@netwok.org> added the comment:
> 
> Thanks for the report.  Setuptools is not a part of Python, and distutils docs don’t mention issues specific to third-party tools.  I think I will reject this bug.
> 
> ----------
> assignee: docs@python -> eric.araujo
> nosy: +eric.araujo
> status: open -> pending
> 
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue10373>
> _______________________________________
msg121084 - (view) Author: Fred L. Drake, Jr. (fdrake) (Python committer) Date: 2010-11-12 22:00
> perhaps the web page should be checked for an incorrect link.

The link from the Python documentation to the Python bug tracker is fine.

If you were using distutils directly, it would be an issue for the Python tracker.

You're not.  setuptools is a separate project; you should refer to it's documentation and it's tracker.
History
Date User Action Args
2010-11-12 22:04:25eric.araujosetresolution: rejected -> not a bug
stage: resolved
2010-11-12 22:00:37fdrakesetstatus: open -> closed

nosy: + fdrake
messages: + msg121084

resolution: rejected
2010-11-12 21:53:33lensartsetstatus: pending -> open

messages: + msg121083
2010-11-12 17:21:53eric.araujosetstatus: open -> pending

nosy: + eric.araujo
messages: + msg121048

assignee: docs@python -> eric.araujo
2010-11-09 13:09:05lensartcreate