classification
Title: Improve the hackish runtime_library_dirs support for gcc
Type: behavior Stage:
Components: Distutils Versions: Python 3.1, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: GCC detection for runtime_library_dirs when ccache is used
View: 1254718
Assigned To: loewis Nosy List: alexandre.vassalotti, loewis, sanxiyn, tarek
Priority: normal Keywords: patch

Created on 2007-08-26 23:07 by alexandre.vassalotti, last changed 2009-06-10 02:11 by alexandre.vassalotti. This issue is now closed.

Files
File name Uploaded Description Edit
better_gcc_detection.patch alexandre.vassalotti, 2007-08-26 23:09
better_gcc_detection-2.patch alexandre.vassalotti, 2007-08-28 15:53
Messages (3)
msg55317 - (view) Author: Alexandre Vassalotti (alexandre.vassalotti) * (Python committer) Date: 2007-08-26 23:07
In distutils.unixccompiler, there is a hack to passing correctly the -R
option to gcc (and a few other compilers). However, there is a small bug
   that causes gcc to not be detected correctly if the compiler name
does not start with "gcc" (e.g., "i486-linux-gnu-gcc", or "ccache gcc").
msg55345 - (view) Author: Seo Sanghyeon (sanxiyn) Date: 2007-08-28 01:14
The patch is incorrect since find returns -1 on failure. This is also a
duplicate of #1254718.
msg55375 - (view) Author: Alexandre Vassalotti (alexandre.vassalotti) * (Python committer) Date: 2007-08-28 15:53
> The patch is incorrect since find returns -1 on failure.

Oops, that is right. I attached the corrected patch.
History
Date User Action Args
2009-06-10 02:11:36alexandre.vassalottisetstatus: open -> closed
resolution: duplicate
superseder: GCC detection for runtime_library_dirs when ccache is used
2009-02-05 16:47:07tareksetversions: - Python 2.6, Python 3.0
2009-02-05 16:38:21akitadasetnosy: + tarek
type: compile error -> behavior
versions: + Python 2.6, Python 3.0, Python 3.1, Python 2.7
2007-09-17 07:29:53jafosetpriority: normal
assignee: loewis
nosy: + loewis
2007-09-02 20:09:03loewissetkeywords: + patch
2007-08-28 15:53:22alexandre.vassalottisetfiles: + better_gcc_detection-2.patch
messages: + msg55375
2007-08-28 01:14:05sanxiynsetnosy: + sanxiyn
messages: + msg55345
2007-08-26 23:09:58alexandre.vassalottisetfiles: + better_gcc_detection.patch
2007-08-26 23:07:36alexandre.vassalotticreate