classification
Title: distutils ignores configure's --includedir
Type: behavior Stage:
Components: Distutils Versions: Python 3.0, Python 3.1, Python 2.7, Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Use directories from configure rather than hardcoded
View: 858809
Assigned To: tarek Nosy List: akitada, josephwinston, matejcik, orsenthil, tarek
Priority: normal Keywords:

Created on 2004-08-31 14:37 by josephwinston, last changed 2010-08-11 05:49 by eric.araujo. This issue is now closed.

Messages (4)
msg60561 - (view) Author: Joseph Winston (josephwinston) Date: 2004-08-31 14:37
1. configure and build python using the --includedir
option.  For example:

$ configure --prefix=/TANGO/3/rel
--includedir=/TANGO/3/rel/inc

2. Run

$ make install

3. Notice that the include files are placed in
/TANGO/3/rel/include not /TANGO/3/rel/inc.

4. Verify with

$ python -c 'from distutils.sysconfig import *;print
get_python_inc()

5. The problem is that get_python_inc() hard codes the
include file path to use the name "include"

6. Other programs using distutils will fail since the
INSTALL_SCHEMES found in install.py also have the name
"include" hard coded.

7.  Suggested fix would be to use --includedir to
calculate the include path used by distutils.



msg81098 - (view) Author: Akira Kitada (akitada) * Date: 2009-02-03 21:21
I'm having the same problem.
This is a real headache, especially on systems that
run both 32-bit and 64-bit apps, where I often see 
"lib64", "include64" and "bin64".

In my opinion, lib, include and bin shouldn't be hard-coded in anywhere.

Note that these hard-coded paths are found in other places, too.
See http://bugs.python.org/issue1294959 for further detials.
msg92542 - (view) Author: Akira Kitada (akitada) * Date: 2009-09-12 12:46
I think this is duplicate of issue858809.
msg92608 - (view) Author: Senthil Kumaran (orsenthil) * (Python committer) Date: 2009-09-14 13:11
Yes, this is a duplicate of issue858809 and tarek is assigned to that
one too.
History
Date User Action Args
2010-08-11 05:49:28eric.araujosetsuperseder: Use directories from configure rather than hardcoded
2009-09-14 13:11:09orsenthilsetstatus: open -> closed

nosy: + orsenthil
messages: + msg92608

resolution: duplicate
2009-09-12 12:46:36akitadasetmessages: + msg92542
2009-03-10 17:18:04matejciksetnosy: + matejcik
2009-02-04 16:42:41akitadasettype: behavior
2009-02-04 16:34:58tareksetassignee: tarek
versions: + Python 2.6, Python 3.0, Python 3.1, Python 2.7
2009-02-03 21:21:04akitadasetnosy: + tarek, akitada
messages: + msg81098
2004-08-31 14:37:25josephwinstoncreate