classification
Title: eval error
Type: behavior Stage:
Components: Versions: Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Rayfward, georg.brandl
Priority: normal Keywords:

Created on 2007-08-24 19:59 by Rayfward, last changed 2007-08-24 20:03 by georg.brandl. This issue is now closed.

Messages (2)
msg55272 - (view) Author: Ray Ward (Rayfward) Date: 2007-08-24 19:59
>>> eval("9")
9
Works but.
>>> eval("09")
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "<string>", line 1
    09
    ^
SyntaxError: invalid token
msg55273 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2007-08-24 20:03
This is not a bug. Integers beginning with "0" are octal literals in Python 2.x,
and "9" is not a valid octal digit.

Closing as Invalid.
History
Date User Action Args
2007-08-24 20:03:50georg.brandlsetstatus: open -> closed
nosy: + georg.brandl
messages: + msg55273
resolution: not a bug
2007-08-24 19:59:24Rayfwardcreate