classification
Title: ctrl-left/-right works incorectly with diacritics
Type: behavior Stage: test needed
Components: Tkinter Versions: Python 2.6
process
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: Nosy List: gpolo, kbk, sophros
Priority: normal Keywords:

Created on 2004-08-19 19:40 by sophros, last changed 2009-04-22 19:37 by gpolo. This issue is now closed.

Messages (3)
msg22143 - (view) Author: Krzysztof Wilkosz (sophros) Date: 2004-08-19 19:40
When left- or right-going in line with ctrl-arrow
(left/right) I have encountered problems:

example word with polish (cp1250) diacritics: za|óB
(last 4 letters might be unreadable) this keybord
shortcut stops each time diacritic letter is
encountered, not at the end of the word. It is
frustrating as I have many strings and comments in
Polish. I thing it might work bad also in the case of
any other non-ASCII letters.
msg22144 - (view) Author: Kurt B. Kaiser (kbk) * (Python committer) Date: 2006-07-23 20:45
Logged In: YES 
user_id=149084

The control-{right,left} action appears to be
implemented in Tkinter, probably in Tcl/Tk, it's
not an IDLE issue.

Someone should check if the problem exists in 
Tk.  Passing this on to the Tkinter crew.
msg86320 - (view) Author: Guilherme Polo (gpolo) * (Python committer) Date: 2009-04-22 19:37
This is not a bug in tkinter either, unfortunately. Please report it at
tk tracker: http://sourceforge.net/projects/tktoolkit/

Here is the equivalent tcl code to reproduce the problem (you could use
it while re-reporting at the tk tracker):

$ wish8.5
% pack [text .t]
% .t insert 1.0 abc
% .t insert 1.0 "z\u0102\u02c7"
History
Date User Action Args
2009-04-22 19:37:52gpolosetstatus: open -> closed
resolution: wont fix
messages: + msg86320
2009-04-22 15:22:24ajaksu2setnosy: + gpolo
2009-02-14 14:43:58ajaksu2setstage: test needed
type: behavior
versions: + Python 2.6, - Python 2.3
2004-08-19 19:40:12sophroscreate