classification
Title: 'import' operator doesn't work with unicode non 7-bit ASCII module names (OS: windows)
Type: behavior Stage:
Components: Interpreter Core, Unicode Versions: Python 3.1, Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Rewrite import machinery to work with unicode paths
View: 9425
Assigned To: Nosy List: Valery.Lesin, brett.cannon
Priority: normal Keywords:

Created on 2010-10-13 08:32 by Valery.Lesin, last changed 2010-10-13 16:48 by brett.cannon. This issue is now closed.

Messages (2)
msg118505 - (view) Author: Valery Lesin (Valery.Lesin) Date: 2010-10-13 08:32
OS: windows

The attempt to import module with non 7-bit ASCII name results in 
'ImportError: No module named <module name>' exception.


Some thoughts: import.c uses functions like fopen, stat and FindFirstFile which wouldn't work correctly with non 7-bit ASCII filenames in Windows.
msg118544 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2010-10-13 16:48
This is a duplicate of 9425
History
Date User Action Args
2010-10-13 16:48:37brett.cannonsetstatus: open -> closed
resolution: duplicate
2010-10-13 16:48:24brett.cannonsetsuperseder: Rewrite import machinery to work with unicode paths

messages: + msg118544
nosy: + brett.cannon
2010-10-13 08:32:47Valery.Lesincreate