Again, thanks for your prompt explanation.

It's odd, but when I went to use Ubuntu's menu modification tool, the command displayed in the dialog didn't show the -n option.

But when I added the Python launcher to the panel and viewed the launch command via the properties dialog, the -n was there and I was easily able to remove it.

So if I run Python from the modified icon in the panel, it launches without the -n option. But if I run it from the Application Menu, it runs without the -n option. It seems to me that the -n option should be available when viewing it from the menu modification tool, but it's not.

I guess Windows doesn't have this problem with running IDLE with a subprocess. I was able to run several instances of the IDLE shell with the Shell menu displayed.



On Tue, 2009-06-02 at 00:53 +0000, Roger Serwy wrote:
Roger Serwy <roger.serwy@gmail.com> added the comment:

You'll need to modify the IDLE menu item to remove the "-n" using
Ubuntu's menu modification tool, usually found under System->Preferences.

Presently, using a subprocess only allows for one instance of IDLE
running on a machine, whereas running with no subprocess allows for many
instances of IDLE. This architecture is by design.

Check out Ubuntu bug 338379.

----------

_______________________________________
Python tracker <report@bugs.python.org>
<http://bugs.python.org/issue6168>
_______________________________________