Issue11

If you're reporting an issue for setuptools 0.7 or higher, please use BitBucket

Title bdist_wininst adds duplicate entry to dist_files
Priority bug Status resolved
Superseder Nosy List htgoebel, pje
Assigned To Keywords

Created on 2008-05-23.17:37:41 by htgoebel, last changed 2008-08-21.18:54:47 by pje.

Files
File name Uploaded Type Edit Remove
simple-0.0.0.0.1.tar.gz htgoebel, 2008-05-23.17:37:40 application/x-gzip
Messages
msg99 (view) Author: pje Date: 2008-08-21.18:54:47
Fixed in trunk and branch.
msg76 (view) Author: pje Date: 2008-08-05.16:01:06
This has bugged me too, but I'm not clear on exactly what the problem is. 
Patches welcome.
msg15 (view) Author: htgoebel Date: 2008-05-23.17:37:40
In setuptools 0.6c8 has a bug in bdist_wininst:

Distribution files are listed twice
``distribution.dist_files``. This hinders developing tools which use
this data. In addition ``upload`` will upload the file twice to pypi.

I need this bug fixed for automated upload of files using
<http://origo-submit.origo.ethz.ch>;;.

Enclosed please find a simple package to show the bug. Just run

   python setup.py bdist_wininst

this shows one entry. Now run

   python setup-setuptools.py bdist_wininst

this shows two entires.

The only difference between both setup files is wherefrom setup() is
imported.
History
Date User Action Args
2008-08-21 18:54:47pjesetstatus: chatting -> resolved
messages: + msg99
keyword: - needpatch
2008-08-05 16:01:06pjesetstatus: unread -> chatting
nosy: + pje
messages: + msg76
keyword: + needpatch
2008-05-23 17:37:42htgoebelcreate