Author pitrou
Recipients Arfrever, Ramchandra Apte, amaury.forgeotdarc, barry, djc, dmalcolm, doko, ezio.melotti, foom, gagern, haypo, jwilk, lemburg, loewis, merwok, neologix, petri.lehtinen, pitrou, python-dev, r.david.murray, rosslagerwall, sandro.tosi
Date 2011-08-18.16:13:52
SpamBayes Score 2.71695e-09
Marked as misclassified No
Message-id <1313683902.3602.13.camel@localhost.localdomain>
In-reply-to <20110818120951.11463316@resist.wooz.org>
Content
> Correct.  We can't touch Python 3.1, 2.6, or earlier because those are all in
> security-only mode, and unless a specific security related issue is
> identified, the change should not be made there.  That's just life (a recent
> similar example is support for multiarch in newer Debian and Ubuntu releases -
> we just don't support that in security-only Pythons).
> 
> We can and should change Python 3.2 and 2.7 to only report 'linux2' for
> backward compatibility.

It means someone upgrading from 2.6 to 2.7 will see sys.platform change
from "linux3" to "linux2". That breaks compatibility.

> For Python 3.3, we should do the right thing, which IMO is to set sys.platform
> to 'linux' without the version number.  In parallel we can change the stdlib
> tests to use .startswith() and encourage third party developers to use
> .startswith() also.

The latter is already done in the documentation.
History
Date User Action Args
2011-08-18 16:13:53pitrousetrecipients: + pitrou, lemburg, loewis, barry, doko, amaury.forgeotdarc, gagern, foom, haypo, jwilk, djc, ezio.melotti, merwok, Arfrever, r.david.murray, dmalcolm, sandro.tosi, neologix, rosslagerwall, python-dev, petri.lehtinen, Ramchandra Apte
2011-08-18 16:13:52pitroulinkissue12326 messages
2011-08-18 16:13:52pitroucreate