classification
Title: PDF files of python docs have text missing
Type: behavior Stage:
Components: Documentation Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: PDF documentation: long verbatim lines are cut off at right hand side
View: 4173
Assigned To: docs@python Nosy List: amberj, docs@python, eric.araujo, georg.brandl
Priority: normal Keywords:

Created on 2010-09-29 14:54 by amberj, last changed 2013-03-28 11:09 by georg.brandl. This issue is now closed.

Messages (4)
msg117614 - (view) Author: Amber Jain (amberj) Date: 2010-09-29 14:54
CC: docs@python.org

I was planning to print the official python "2.7" tutorial: http://docs.python.org/tutorial/index.html.
So, I went over to Download page: http://docs.python.org/download.html and downloaded the PDF file. But the PDF have some missing text due to width of page being less than number of chars to put on a line.
For example, please have a look at page-21 (Section 3.1.3 titled "Unicode Strings"). It has an incomplete line from HTML documentation.
Here's a screenshot of what I see (and mean):
http://amberj.devio.us/pub/screenshots/pdfdoc.png

There's a line somewhere in the middle of screenshot which goes out of boundary of PDF document and fails to put out-of-boundary text on newline.
From what I had read, it seems that this happens only with 'code snippets' in tutorial. This is probably a problem with convertor (HTML to PDF?).

Can you guys please fix it?
Thanks a lot.
msg117743 - (view) Author: √Čric Araujo (eric.araujo) * (Python committer) Date: 2010-09-30 15:17
It looks like this should be solved in Sphinx.  Can you report this on its tracker at Bitbucket?  Thanks.
msg117815 - (view) Author: Amber Jain (amberj) Date: 2010-10-01 16:31
Reported to sphinx tracker at bitbucket:
http://bitbucket.org/birkenfeld/sphinx/issue/531/pdf-files-of-python-docs-have-text-missing
msg185434 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2013-03-28 11:09
Duplicate of #4173.
History
Date User Action Args
2013-03-28 11:09:21georg.brandlsetstatus: open -> closed
superseder: PDF documentation: long verbatim lines are cut off at right hand side
resolution: duplicate
messages: + msg185434
2010-10-01 16:31:16amberjsetmessages: + msg117815
2010-09-30 15:17:18eric.araujosetnosy: + georg.brandl, eric.araujo
messages: + msg117743
2010-09-29 15:07:52r.david.murraysetassignee: docs@python

type: behavior
components: + Documentation, - None
nosy: + docs@python
2010-09-29 14:54:13amberjcreate