classification
Title: IDLE closes with save while breakpoint open
Type: behavior Stage: resolved
Components: IDLE Versions: Python 3.2, Python 3.3, Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: asvetlov Nosy List: Jimbofbx, asvetlov, python-dev, roger.serwy, terry.reedy
Priority: high Keywords: patch

Created on 2010-09-08 19:42 by Jimbofbx, last changed 2012-07-31 16:54 by asvetlov. This issue is now closed.

Files
File name Uploaded Description Edit
issue9803.patch roger.serwy, 2012-07-18 21:58 review
Messages (6)
msg115894 - (view) Author: James Hutchison (Jimbofbx) Date: 2010-09-08 19:42
I have multiple versions of python - 2.6.1 and 3.1.2. 2.6.1 is the primary install (i.e., right click on a file and "edit with IDLE" brings up 2.6), and was installed first. This issue occurs on 3.1.2, Windows XP 32-bit

If I highlight a breakpoint, run with the debugger, make a change, then save, IDLE will close all windows after saving without an error message. If I clear the breakpoint and then save, IDLE will not close. Reopening the file reveals that the save was successful. I do not need to actually be stopped at a highlighted breakpoint for this to occur (i.e. this will occur if I save at the beginning before the script has ran). If I run with 2.6.1 I do not see this issue. The save difference could be something simple, such as adding a space somewhere random.
msg158293 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2012-04-14 22:28
This is a duplicate of #6257.
msg165810 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2012-07-18 21:50
Reopening. I mistakenly closed this issue as a duplicate, but this issue involves breakpoints, unlike 6257.
msg165813 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2012-07-18 21:58
Attached is a patch to fix the issue. The ranges_to_linenumbers function relies on the results of text.tag_ranges. The returned tuple contains Tk textindex objects. While these objects contain a string, they are not string objects. Its .string value must be used instead.
msg167018 - (view) Author: Roundup Robot (python-dev) Date: 2012-07-31 16:52
New changeset 47536beb7453 by Andrew Svetlov in branch '3.2':
Issue #9803: Don't close IDLE on saving if breakpoint is open.
http://hg.python.org/cpython/rev/47536beb7453

New changeset 28c935ded243 by Andrew Svetlov in branch 'default':
Issue #9803: Don't close IDLE on saving if breakpoint is open.
http://hg.python.org/cpython/rev/28c935ded243

New changeset 8f1a8e80f330 by Andrew Svetlov in branch '2.7':
Issue #9803: Don't close IDLE on saving if breakpoint is open.
http://hg.python.org/cpython/rev/8f1a8e80f330
msg167019 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2012-07-31 16:54
Thanks, Roger!
History
Date User Action Args
2012-09-25 05:05:34roger.serwylinkissue16033 superseder
2012-07-31 16:54:06asvetlovsetstatus: open -> closed
resolution: fixed
messages: + msg167019

stage: patch review -> resolved
2012-07-31 16:52:49python-devsetnosy: + python-dev
messages: + msg167018
2012-07-30 19:10:17asvetlovsetassignee: asvetlov

nosy: + asvetlov
2012-07-18 22:22:03roger.serwylinkissue6257 superseder
2012-07-18 21:58:06roger.serwysetfiles: + issue9803.patch
priority: normal -> high
type: crash -> behavior

versions: + Python 2.7, Python 3.2, Python 3.3, - Python 3.1
keywords: + patch
nosy: + terry.reedy

messages: + msg165813
stage: patch review
2012-07-18 21:50:41roger.serwysetstatus: closed -> open
superseder: Idle terminates on source save while debugging ->
resolution: duplicate -> (no value)
messages: + msg165810
2012-04-14 22:28:37roger.serwysetstatus: open -> closed

nosy: + roger.serwy
messages: + msg158293

superseder: Idle terminates on source save while debugging
resolution: duplicate
2010-09-08 19:42:27Jimbofbxcreate